0 Replies Latest reply on Dec 23, 2006 8:17 PM by Tom Clifford

    HAJNDI error

    Tom Clifford Newbie

      I run JBoss 4.0.4GA on WinXP, and last week I started getting an error
      on JBoss startup:

      11:34:00,314 INFO [RegistryServlet] Initializing jUDDI components.
      11:34:01,345 INFO [DefaultPartition] Initializing
      11:34:01,415 WARN [ServiceController] Problem creating service jboss:service=HA
      JNDI
      java.lang.NoSuchMethodError:
      org.jnp.interfaces.NamingContext.setHANamingServerForPartition(Ljava/lang/String;Lorg/jnp/interfaces/Naming;)V
      at org.jboss.ha.jndi.DetachedHANamingService.createService(DetachedHANam
      ingService.java:353)
      at org.jboss.system.ServiceMBeanSupport.jbossInternalCreate(ServiceMBean
      Support.java:260)
      at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMB
      eanSupport.java:243)

      ....more......

      I run Sun's JSDK 1.5, Apache 2.0.48(Win32), and re-copied ALL the
      XML files from the JBoss distribution back into the \jboss\server\all\deploy
      directory, to no avail. I've even un-deployed ALL my test apps (this
      is a development machine), as well as my mysql-ds.xml and mssql-ds.xml
      files from the deploy dir. Same error.

      Has anyone else had this occur ?

      I cannot think of any changes I've made in the last week or two that
      would have caused this- I don't, as a rule, touch any of the config
      xml files in jboss; I added the /conf/auto/mod_jk.conf to allow
      JBoss to serve apps thru Apache. I had the ALL config running for
      about two weeks before this started.
      I'm at a loss. Thanks for any advice.