2 Replies Latest reply on Nov 12, 2009 6:38 AM by Robert Wilson

    JBoss / Eclipse RCP: Could not dereference object

    Robert Wilson Newbie

      I have a problem instantiating my remote session bean from my Eclipse RCP client. I get a nest of 3 exceptions:

      javax.naming.NamingException: Could not dereference object
      Caused by: java.lang.reflect.UndeclaredThrowableException
      Caused by: java.land.ClassNotFound: company.service.SessionRemote

      Interestingly, this final exception is thrown from the JBoss ClassLoaderUtility. It appears to me that JBoss is overriding Eclipse's ClassLoader, and can't find the relevant class.

      This is definetely an Eclipse/JBoss issue - when I run a standalone JUnit test, all the tests pass. When I run it from an Eclipse plug-in test, it fails.

      Is this normal behvavious? Can I influence the JBoss classloader at all?

      Other key points:

      * There is no output on the server (i.e. client-side issue)
      * Currently both the client and the JBoss server are running from the same JDK