10 Replies Latest reply on May 5, 2005 1:32 PM by mazz

    problems using Slide integration standalone

    mazz Master

      I'm in the process of trying to use the JBoss Portal's Slide integration standalone (that is, just using the CMS war/sar in my own JBoss instance because I need a WebDAV server for some things I'm doing).

      So, I first copied portal-core.sar to my "default" deployment. I only included the .jars found there along with the META-INF directory and portal-cms.sar and portal-cmd.war directories. All other things were not copied over.

      First, it is dependent on JBoss 4.x. I'm installing in a JBoss 3.2.3 and I need the class org.jboss.util.StringPropertyReplacer. So, from a JBoss 4.x distro, I copied jboss-common.jar, deleted all classes from it EXCEPT that StringPropertyReplacer class, and put that one class .jar in portal-cms.sar subdeployment directory. I then got around the ClassNotFound issue.

      But now I'm getting weird errors, that again may or may not be related to the version of JBoss I'm using.

      10:47:11,353 ERROR [STDERR] org.apache.slide.common.ServiceAccessException: Service TxXMLFileDescriptorsStore at C:\mazz\jboss\jboss-3.2-webdav\server\default\data/portal/webdav/store/metadata working on C:\mazz\jboss\jboss-3.2-webdav\server\default\data/portal/webdav/work/metadata access error : (class: org/apache/slide/store/txfile/AbstractXMLResourceDescriptor, method: encodeRevisionDescriptors signature: ()Lorg/jdom/Element;) Incompatible argument to function
      10:47:11,353 ERROR [STDERR] at org.apache.slide.store.AbstractStore.createObject(AbstractStore.java:689)
      10:47:11,353 ERROR [STDERR] at org.apache.slide.store.ExtendedStore.createObject(ExtendedStore.java:602)
      10:47:11,353 ERROR [STDERR] at org.apache.slide.common.Namespace.loadBaseData(Namespace.java:785)
      10:47:11,353 ERROR [STDERR] at org.apache.slide.common.Domain.initNamespace(Domain.java:845)
      10:47:11,353 ERROR [STDERR] at org.apache.slide.common.Domain.init(Domain.java:432)
      10:47:11,353 ERROR [STDERR] at org.apache.slide.common.Domain.init(Domain.java:366)
      10:47:11,353 ERROR [STDERR] at org.jboss.portal.cms.CMS.createService(CMS.java:128)
      10:47:11,353 ERROR [STDERR] at org.jboss.portal.cms.ha.InvalidatableCMS.createService(InvalidatableCMS.java:106)
      10:47:11,353 ERROR [STDERR] at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:158)
      10:47:11,353 ERROR [STDERR] at org.jboss.portal.cms.CMS.create(CMS.java:198)
      


      Do you think this is related to my use of JBoss 3.x or am I missing something that I should have copied over from portal core?

        • 1. Re: problems using Slide integration standalone
          Viet Master

          it seems to be related to slide and I think that would need to use a debugger or look at the source to see what is the reason of that.

          • 2. Re: problems using Slide integration standalone
            Viet Master

            perhaps you Domain.xml is wrong ? did you use your own Domain.xml or you are using the one we bundle with ?

            • 3. Re: problems using Slide integration standalone
              mazz Master

              the one bundled... I actually didn't change anything. I only removed the stuff from the core sar that I didn't think was required of the CMS stuff.

              • 4. Re: problems using Slide integration standalone
                Viet Master

                on 4.0.1sp11 if I do :

                cp $PORTAL_HOME/common/output/lib/portal-common-lib.jar $JBOSS_HOME/server/default/deploy
                cp $PORTAL_HOME/cms/output/lib/portal-cms.sar $JBOSS_HOME/server/default/deploy

                it deploys fine.

                could you try exactly the same with your JBoss distribution ?

                • 5. Re: problems using Slide integration standalone
                  mazz Master

                  Tried it. Had to put portal-common-lib.jar in the CMS sar directory (just in the deploy directory caused a ClassNotFound exception on the "org.jboss.portal.util.XML" class.

                  I then had to copy my jboss-common.jar with that single class in it (StringPropertyReplacer), otherwise I'd get that error as before (this is to be expected).

                  But, no dice. Get the same exception. I'll run this through a debugger to find out what's going on - will let you know what I find.

                  BTW: I am assuming this Slide is the latest 2.1 version. If that is wrong, let me know.

                  • 6. Re: problems using Slide integration standalone
                    Viet Master

                    yes it is, locally I am using : jakarta-slide-server-src-2.1 for debugging

                    • 7. Re: problems using Slide integration standalone
                      mazz Master

                      OK, I solved the problem. The actual exception was a VerifyError on a JDOM class. So, its a class loading issue. (there's a class that is not in the old jdom.jar that ships with JBoss 3.2.3 in /lib that the CMS stuff needs (org.jdom.Content) - this class is in the new jdom.jar that is found in the CMS sar.

                      I just copied the jdom.jar from the cms sar to the JBoss /lib directory. In effect, updating the jdom.jar that comes with the JBoss 3.2.3 to a newer version.

                      The sar deployed successfully when I did this.

                      • 8. Re: problems using Slide integration standalone
                        mazz Master

                        So, now I have the sar deployed, I have to get the web front end defined - so I need the war.

                        I copied the portal-cms.war over. I actually am now keeping with the JBoss Portal binary distribution's directory layout:

                        deploy/portal-core.sar/portal-cms.[sar,war]

                        I was getting a class not found on a class in org.jboss.portal.core.servlet so I copied over portal-core-lib.jar into the portal-core.sar directory.

                        At that point, I can now go to http://localhost:8080/webdav and get my webdav listing!

                        So, all things considered, it wasn't too bad to deploy on JBoss 3.2.3. Needed an updated jdom.jar AND a class from 4.x's jboss-common.jar.

                        The Slide integration from JBoss Portal needed a small piece from JBoss Portal core (portal-core-lib.jar - 334KB) and portal-common-lib.jar (110KB). But other than those two things, the CMS stuff moved over as an independent deployment unit.

                        • 9. Re: problems using Slide integration standalone
                          Viet Master

                          great to hear that that it deploys smoothly.

                          if you have dependency issues between the cms war and the cms sar, you can put a dependency in jboss-web.xml on the CMS service.

                          also the cms war file contains a specific setting for security related to jboss portal. it uses the specific java:jaas/webdav security domain and a specific filter org.jboss.portal.core.servlet.StaticPrincipalFilter.

                          you may want to remove that.

                          • 10. Re: problems using Slide integration standalone
                            mazz Master

                            Oh.. OK... that filter is what caused the need to pull in the core .jar. Once I took that out, no need for the portal-core-lib.jar. :)