3 Replies Latest reply on Jun 2, 2005 9:42 AM by jkester

    Theme not visible under Linux Debian, 2.0RC2

    jkester Newbie

      Hello

      I downloaded the 2.0RC2 release with jboss included and deployed it under windows with mysql. All worked well.
      I then took the same zip, and deployed it on a remote linux machine, debian, with jdk 1.4 (using postgres).
      The strange thing is, that the page on linux does not show any theme, but all pages are presented as unformatted text.
      How is it possible?
      Some differences:
      remote machine firewall?
      remote machine uses apache mod_jk to forward portal traffic to jboss-tomcat
      remote machine uses postgres
      remote machine is linux, local windows

      Where should I start looking to find out what is missing there. The code base is similar.

      Any idea?

      Regards Jan

        • 1. Re: Theme not visible under Linux Debian, 2.0RC2
          jkester Newbie

          I think this has to do something with url forwarding.
          I have an apache mod_jk installed with a workers.properties that redirects all
          traffic to jboss. The setting for this is:
          [uri:/portal/*]
          I guess that themes are loaded by faces/struts (?) and that some internal url is not properly resolved. I say this as I noticed as well with this configuration that a login goes to //portal instead of going to /portal.
          Somewhere in the link direction/templates things go wrong maybe?

          Hmm, looking in my code though I do see:
          , but no stylesheet gets loaded.
          Actually also no images get loaded.

          Have a look at http://www.jankester.com/portal

          Regards, Jan

          • 2. Re: Theme not visible under Linux Debian, 2.0RC2
            Martin Giljohann Newbie

             

            "jkester" wrote:
            I have an apache mod_jk installed with a workers.properties that redirects all traffic to jboss. The setting for this is:
            [uri:/portal/*]

            I think this is really just related to the jk connector. To see all the design stuff try adding
            [uri:/portal-core/*]
            [uri:/portal-forums/*]

            Furthermore your portal is titled "...2.0 Release Candidate",
            whereas your cms fragment is labelled "...v2.0 Alpha Release". With my installation both titles refer to the same portal version - maybe this is another reason for some problems.

            • 3. Re: Theme not visible under Linux Debian, 2.0RC2
              jkester Newbie

              Super

              the URI thing solved the problem, so for my theme portal-core was not forwarded.

              About the inconsistency of naming:
              a few days ago I downloaded jboss-portal-2.0-RC2-jboss-4.0.2
              Both my windows and my linux version have a file index_1.0.html here that contains the word "Alpha Release".
              The index.jsp of portal-core/nodesk/ on the other hand has the word Release in it. Could it be there have been released more 2.0RC2 versions?

              Regards, Jan.