3 Replies Latest reply on Jun 29, 2005 8:29 AM by vinkh

    Unable to deploy the Sample Spring MVC Portal

    echoi1975 Newbie

      did you check the xml config files in WEB-INF to make sure they are well-formed?

        • 1. Re: Unable to deploy the Sample Spring MVC Portal
          Roy Russo Master

          I'm almost done fixing it and updating the entire sample wiki page. Will let you know when complete.

          • 2. Re: Unable to deploy the Sample Spring MVC Portal
            vinkh Newbie

            I am using "jboss-portal-2.0-jboss-4.0.2" and getting the same error - org.jboss.portal.common.util.NoSuchElementException: Missing child component-ref of element instance

            See the sample xml code -
            --portlet.xml
            <portlet-app>

            <portlet-name>MyTest</portlet-name>
            <display-name>My test</display-name>
            <portlet-class>mypackage.MyTest</portlet-class>
            <expiration-cache>0</expiration-cache>

            <mime-type>text/html</mime-type>
            <portlet-mode>EDIT</portlet-mode>
            <portlet-mode>HELP</portlet-mode>


            </portlet-app>

            --jboss-app.xml
            <jboss-app>
            <app-name>MyTest</app-name>
            </jboss-app>

            --jboss-portlet.xml
            <portlet-app>

            <portlet-name>mytest</portlet-name>

            </portlet-app>

            --portlet-instances.xml
            <?xml version="1.0" standalone="yes"?>


            <instance-name>MyTestInstance</instance-name>
            <component-name>MyTest</component-name>



            --mytest-pages.xml

            <portal-name>default</portal-name>

            <page-name>mytest</page-name>

            <window-name>MyTestWindow</window-name>
            <instance-ref>mytest.MyTest.MyTestInstance</instance-ref>
            true
            left
            0




            i tried to get the samples from http://wiki.jboss.org/wiki/Wiki.jsp?page=JBossPortalSamples, which unfortunately is not accessible for last 2 days!!

            i didn't define the *-portal.xml since i am using default. Any error in above xmls ?

            Could you send or paste some working samples ?

            • 3. Re: Unable to deploy the Sample Spring MVC Portal
              vinkh Newbie

              its fine now. the tag name should be <component-ref> and NOT <component-name>