0 Replies Latest reply on Jun 22, 2005 9:11 AM by Jason Yonan

    Unable to delete or edit forum posts

    Jason Yonan Newbie

      I have installed jboss 4.0.2 with portal/forum 2.0 running on jdk 1.5 and I am unable to either delete or edit forum topics/posts under the admin login. I have tried using both a postresql db and the default hsqldb. I post to a forum and the forum index has "Second forum - 1 - 1 - Edit - Delete - etc." Then click on forum link, post link, finally the "X" link, and it asks to delete then throws this error:

      08:51:34,809 WARN [JDBCExceptionReporter] SQL Error: 0, SQLState: null
      08:51:34,809 ERROR [JDBCExceptionReporter] failed batch
      08:51:34,810 ERROR [AbstractFlushingEventListener] Could not synchronize database state with session
      org.hibernate.exception.GenericJDBCException: Could not execute JDBC batch update
       at org.hibernate.exception.ErrorCodeConverter.handledNonSpecificException(ErrorCodeConverter.java:92)
       at org.hibernate.exception.ErrorCodeConverter.convert(ErrorCodeConverter.java:80)
       at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43)
       at org.hibernate.jdbc.AbstractBatcher.executeBatch(AbstractBatcher.java:179)
       at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:226)
       at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:141)
       at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:274)
       at org.hibernate.event.def.DefaultAutoFlushEventListener.onAutoFlush(DefaultAutoFlushEventListener.java:48)
       at org.hibernate.impl.SessionImpl.autoFlushIfRequired(SessionImpl.java:697)
       at org.hibernate.impl.SessionImpl.prepareQueries(SessionImpl.java:881)
       at org.hibernate.impl.SessionImpl.getQueries(SessionImpl.java:871)
       at org.hibernate.impl.SessionImpl.list(SessionImpl.java:820)
       at org.hibernate.impl.QueryImpl.list(QueryImpl.java:74)
       at org.hibernate.impl.AbstractQueryImpl.uniqueResult(AbstractQueryImpl.java:603)
       at org.jboss.portlet.forums.impl.ForumsModuleImpl.findLastPost(ForumsModuleImpl.java:880)
       at org.jboss.portlet.forums.commands.post.DeletePostCommand.__execute(DeletePostCommand.java:96)
       at org.jboss.portlet.forums.commands.post.ForumCommand.execute(ForumCommand.java:163)
       at org.jboss.portal.common.command.filter.ExecuteFilter.filter(ExecuteFilter.java:25)
       at org.jboss.portlet.forums.interceptors.FloodControlInterceptor.filter(FloodControlInterceptor.java:87)
       at org.jboss.portlet.forums.interceptors.NotificationInterceptor.filter(NotificationInterceptor.java:122)
       at org.jboss.portal.common.command.filter.CompositeFilter.filter(CompositeFilter.java:41)
       at org.jboss.portlet.forums.ForumsPortlet.posting(ForumsPortlet.java:576)
      


      Topic/post is still there, but forum index now has "Second forum - 0 - 0 - Edit - etc"