1 Reply Latest reply on Aug 29, 2005 6:40 AM by Kent C

    Portlet is registered but not dispalying/rendering on the we

    Kent C Newbie

      Hi,

      I am using JBoss portal 2.0 which comes bundled with JBoss 4.0.2 on Win XP.

      I am a newbie tried to follow the Helloworld example to create a new portlet and worked fine which displayed some links. Then I tried to add one more portlet by defining the same way as first portlet created but something went wrong and neither one renders/displayed.

      So now I am back to one but even one portlet is not reendering now. What would be the problem. My portlet is registered,appears in the menu and inited properly as I can see the init message from the portlet.

      It looks like the invocation to the portlet works fine and from logs looks like it should render fine but doesn't ??????????. I also made sure the VIEW mode is defined for the portlet. Below are the logs of invocaion


      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.server.impl.invocation.InvocationImpl] Incoming request with id page.default.TestPortlet1
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.ContentTypeInterceptor] Found markup=html_web_4_0, ua=Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322), devicedID=goodaccess_ver1_submsiepocketpc
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.ContentTypeInterceptor] Found mimeType type text/html for markup=html_web_4_0
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] analyzing layout strategy....
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.server.impl.LayoutServerImpl] get nodesk...
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.server.impl.LayoutServerImpl] found nodesk
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] looking for a layout strategy [default] [TestPortlet1] [nodesk] [text/html]
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] got a layout: trying to get the strategy from it...
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] no strategy from the layoutlayout: trying to get named strategy...
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] looking for strategy with name: default
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] found strategy to use: org.jboss.portal.core.theme.strategy.impl.DefaultStrategyImpl
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] adding region: center
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.theme.strategy.StrategyFactory] creating strategy context for: nodesk default TestPortlet1
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.theme.strategy.impl.DefaultStrategyImpl] evaluating strategy for: org.jboss.portal.core.theme.impl.PortalLayoutImpl@b1406b
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] setting layout URI: /nodesk/index.jsp
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.invocation.StrategyInterceptor] done analyzing layout strategy
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.servlet.CoreServlet] requesting theme: null
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.servlet.CoreServlet] using layout returned from the strategy: nodesk uri: /nodesk/index.jsp
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.core.servlet.CoreServlet] got layout to use [nodesk] in app [portal] uri [/nodesk/index.jsp]
      2005-08-28 06:58:49,730 DEBUG [org.jboss.portal.server.theme.LayoutDispatcher] got request dispatcher for layout resource: true
      2005-08-28 06:58:49,740 DEBUG [org.jboss.portal.server.theme.LayoutDispatcher] done with the layout