6 Replies Latest reply on Sep 16, 2005 9:06 AM by Thomas Heute

    JBoss portal table doesn't exist - Starting failed portal:se

    Jeff Newbie

      I've got the same copy of JBoss portal on each machine.
      One machine running Oracle 10g works,
      Seconds machine running MySQL fails with the following stack trace.
      Also a third machine with Oracle seems to fail with the same error.

      Can someone please point me in the right direction?

      Note: portal-mysql-ds.xml contains the correct settings.
      I have correct driver.
      The user in portal-mysql-ds.xml has all right and can access the DB.
      I am administrator on my local machine.

      mysql-connector-java-3.1.10-bin.jar
      
      

      
      portal-mysql-ds.xml...
      <?xml version="1.0" encoding="UTF-8"?>
      <datasources>
       <local-tx-datasource>
       <jndi-name>PortalDS</jndi-name>
       <connection-url>jdbc:mysql://localhost:3306/jbport?useServerPrepStmts=false</connection-url>
       <driver-class>org.gjt.mm.mysql.Driver</driver-class>
       <user-name>monty</user-name>
       <password>password</password>
       </local-tx-datasource>
      </datasources>
      




      15:40:26,612 INFO [SessionFactoryBinder] Hibernate dialect used null
      15:40:27,237 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
      15:40:27,237 ERROR [JDBCExceptionReporter] Table 'jbport.jbp_user_pref_set' doesn't exist
      15:40:27,299 ERROR [SessionFactoryBinder] Starting failed portal:service=Hibernate
      org.hibernate.HibernateException: The dialect was not set. Set the property hibernate.dialect.
       at org.hibernate.dialect.Dialect.getDialect(Dialect.java:540)
       at org.hibernate.dialect.Dialect.getDialect(Dialect.java:562)
       at org.hibernate.tool.hbm2ddl.SchemaExport.<init>(SchemaExport.java:77)
       at org.hibernate.tool.hbm2ddl.SchemaExport.<init>(SchemaExport.java:53)
      


        • 1. Re: JBoss portal table doesn't exist - Starting failed porta
          Jeff Newbie

          I downloaded ..

          jboss-forums-2.0.zip

          and over-wrote the files I have.

          I then changed the file...

          portal-forums.ear\portal-forums.sar\conf\hibernate\hibernate.cfg.xml

          To select the MySQL dialect directly.

          Now the tables get created when I start JBoss.
          Although I'm left with the following error messages...




          16:27:56,700 INFO [EARDeployer] Started J2EE application: file:/C:/tools/jboss-4.0.2-PORTAL/server/all/deploy/portal-fo
          rums.ear/
          16:27:56,841 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
          
          --- MBeans waiting for other MBeans ---
          ObjectName: jboss.ha:service=HASingletonDeployer
           State: CONFIGURED
           I Depend On:
           jboss:service=DefaultPartition
           jboss.system:service=MainDeployer
          
          ObjectName: jboss:service=FarmMember,partition=DefaultPartition
           State: CONFIGURED
           I Depend On:
           jboss:service=DefaultPartition
           jboss.web:service=WebServer
           jboss.system:service=MainDeployer
          
          --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
          ObjectName: jboss:service=DefaultPartition
           State: NOTYETINSTALLED
           Depends On Me:
           jboss.ha:service=HASingletonDeployer
           jboss:service=FarmMember,partition=DefaultPartition
          
          
          16:27:57,185 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
          16:27:57,669 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
          16:27:57,700 INFO [JkMain] Jk running ID=0 time=0/94 config=null
          16:27:57,731 INFO [Server] JBoss (MX MicroKernel) [4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)] Started in 1m:9
          s:811ms
          16:28:05,544 INFO [STDOUT] 01-Sep-2005 16:28:05 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger l
          ogInfo
          INFO: [async_echo.bpr] Starting ActiveBpel deployment.
          16:28:08,716 INFO [STDOUT] 01-Sep-2005 16:28:08 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [async_echo.bpr] Finished ActiveBpel deployment.
          16:28:08,794 INFO [STDOUT] 01-Sep-2005 16:28:08 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [async_echo_web_services.wsr] Starting WebServices deployment.
          16:28:08,794 INFO [STDOUT] 01-Sep-2005 16:28:08 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [async_echo_web_services.wsr] Deploying META-INF\service.wsdd
          16:28:08,856 INFO [STDOUT] 01-Sep-2005 16:28:08 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [async_echo_web_services.wsr] Finished WebServices deployment.
          16:28:08,872 INFO [STDOUT] 01-Sep-2005 16:28:08 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [BPELTestProcess.bpr] Starting ActiveBpel deployment.
          16:28:09,247 INFO [STDOUT] 01-Sep-2005 16:28:09 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [BPELTestProcess.bpr] BPELTestProcess.pdd generated warnings. See deployment log.
          16:28:09,263 INFO [STDOUT] 01-Sep-2005 16:28:09 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: [BPELTestProcess.bpr] Finished ActiveBpel deployment.
          16:28:09,263 INFO [STDOUT] 01-Sep-2005 16:28:09 org.activebpel.rt.axis.bpel.web.AeProcessEngineServlet$AeTomcatLogger logInfo
          INFO: ********** ActiveBPEL In-Memory Configuration Started


          • 2. Re: JBoss portal table doesn't exist - Starting failed porta
            Viet Master

            this error message does not seem related to jboss portal ....

            • 3. Re: JBoss portal table doesn't exist - Starting failed porta
              M Litherland Newbie

              Hi,

              I'm having the same problem trying to get JBoss Portal installed. As far as I'm concerned it is a portal problem if I'm following the install instructions and it neglects to mention something like this that prevents the product from working.

              There are other problems as well. The install says:
              >The downloaded archive contains the following files:
              >
              > * jboss-portal.sar
              > * portal-forums.ear
              > * /setup/portal-*-ds.xml

              But that looks nothing like what the zip file contains. In reality it contains a directory called "jboss-portal.sar" and none called "portal-forums.ear". So right off the bat we know there's an issue with the documentation.

              At any rate, I can't find anywhere that tells me the right place to set the hibernate.property dialect. There are .properties files all over the place and it would be nice to know that I'm doing things the right way instead of fumbling around until it works.

              Thanks,

              • 4. Re: JBoss portal table doesn't exist - Starting failed porta
                M Litherland Newbie

                Hi again,

                It looks like the "right" place to configure your hibernate for portal is in this file:

                jboss-portal.sar/conf/hibernate/hibernate.cfg.xml

                I would ask someone at JBoss to please update their docs to include this information as well as other incorrect information about the portal install.

                Thanks,
                M Litherland

                • 5. Re: JBoss portal table doesn't exist - Starting failed porta
                  Thomas Heute Master

                   

                  "litherm" wrote:

                  There are other problems as well. The install says:
                  >The downloaded archive contains the following files:
                  >
                  > * jboss-portal.sar
                  > * portal-forums.ear
                  > * /setup/portal-*-ds.xml


                  portal-forums in now available from another archive.
                  jboss-portal.sar and /setup/portal-*-ds.xml are available in the binary package.
                  (.sar as a compressed file or a directory does not make any difference inside JBoss)

                  • 6. Re: JBoss portal table doesn't exist - Starting failed porta
                    Thomas Heute Master

                    And from the documentation: http://docs.jboss.com/jbportal/v2.0Final/user-guide/en/html/installation.html#d0e679

                    "If you encounter that the Hibernate dialect is not working properly and would like to override the default behaviour, you simply need to modify jboss-portal.sar/conf/hibernate/hibernate.cfg.xml."

                    That's if you don't want to use the autodetection.