3 Replies Latest reply on Oct 6, 2005 12:12 PM by Roy Russo

    JBP 2.2 Alpha - Jackrabbit configuration exception on startu

    dunks80 Newbie

      JBoss Portal 2.2 Alpha from cvs
      JBoss AS 4.0.3RC2
      Fedora Core 4
      MySQL 4.0

      I'm getting the following error when starting JBP 2.2

      org.apache.jackrabbit.core.config.ConfigurationException: Failed to load the created configuration for workspace default.
       at org.apache.jackrabbit.core.config.RepositoryConfig.createWorkspaceConfig(RepositoryConfig.java:330)
       at org.apache.jackrabbit.core.config.RepositoryConfig.init(RepositoryConfig.java:218)
       at org.apache.jackrabbit.core.config.RepositoryConfig.create(RepositoryConfig.java:97)
       at org.apache.jackrabbit.core.config.RepositoryConfig.create(RepositoryConfig.java:71)
       at org.apache.jackrabbit.core.jndi.BindableRepository.init(BindableRepository.java:114)
       at org.apache.jackrabbit.core.jndi.BindableRepository.create(BindableRepository.java:104)
       at org.apache.jackrabbit.core.jndi.RegistryHelper.registerRepository(RegistryHelper.java:57)
       at org.jboss.portal.cms.util.RepositoryUtil.registerRepository(RepositoryUtil.java:68)
       at org.jboss.portal.cms.impl.jcr.JCRCMS.startService(JCRCMS.java:174)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:287)
       at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:187)
       at org.jboss.portal.common.system.AbstractJBossService.start(AbstractJBossService.java:73)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:141)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:80)
       at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:118)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:74)
       at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:127)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:74)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:245)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:644)
       at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:991)
       at $Proxy0.start(Unknown Source)
      snipped...
      


      when i take a look at the repository file system that the portal is trying to set up I come across this

      > pwd
      >/usr/local/dst/jboss/jboss-4.0.3RC2/server/portal/data/portal/cms/jcr/workspaces
      >ls -l
      >total 8
      drwxrwxr-x 2 jboss jboss 4096 Oct 4 19:40 default
      -rw-rw-r-- 1 jboss jboss 945 Oct 4 19:41 default\workspace.xml

      I'm thinking the 'default\workspace.xml' file is in the wrong place with the wrong name. If i move the file into the default folder and rename it workspace.xml the portal deploys fine. So did I screw up the build or is this an actual bug?