0 Replies Latest reply on Feb 17, 2006 11:18 AM by Pierre Månsson

    Installation problem

    Pierre Månsson Newbie

      Hello Im trying to install jboss portal with mysql on windows I have also tried with jdk 1.4.2 I have tried to include a jar file with the missing class but I get a new error, I get following error when I start the server the first time!
      Any ideas of what I can have missing :( ???
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\Program\jboss-4.0.3SP1\bin\\..
      .
      JAVA: C:\Program Files\Java\jdk1.5.0_06\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
      .
      CLASSPATH: C:\Program Files\Java\jdk1.5.0_06\lib\tools.jar;C:\Program\jboss-4.
      0.3SP1\bin\\run.jar
      .
      ===============================================================================
      .
      17:08:35,129 INFO [Server] Starting JBoss (MX MicroKernel)...
      17:08:35,129 INFO [Server] Release ID: JBoss [Zion] 4.0.3SP1 (build: CVSTag=JBo
      ss_4_0_3_SP1 date=200510231751)
      17:08:35,129 INFO [Server] Home Dir: C:\Program\jboss-4.0.3SP1
      17:08:35,129 INFO [Server] Home URL: file:/C:/Program/jboss-4.0.3SP1/
      17:08:35,129 INFO [Server] Patch URL: null
      17:08:35,129 INFO [Server] Server Name: default
      17:08:35,129 INFO [Server] Server Home Dir: C:\Program\jboss-4.0.3SP1\server\de
      fault
      17:08:35,129 INFO [Server] Server Home URL: file:/C:/Program/jboss-4.0.3SP1/ser
      ver/default/
      17:08:35,129 INFO [Server] Server Temp Dir: C:\Program\jboss-4.0.3SP1\server\de
      fault\tmp
      17:08:35,129 INFO [Server] Root Deployment Filename: jboss-service.xml
      17:08:35,442 INFO [ServerInfo] Java version: 1.5.0_06,Sun Microsystems Inc.
      17:08:35,442 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_06-b05
      ,Sun Microsystems Inc.
      17:08:35,442 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      17:08:35,833 INFO [Server] Core system initialized
      17:08:36,693 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resour
      ce:log4j.xml
      17:08:39,616 ERROR [MainDeployer] Could not create deployment: file:/C:/Program/
      jboss-4.0.3SP1/server/default/deploy/jboss-portal.sar/
      java.lang.NoClassDefFoundError: javax/activation/MimeTypeParseException
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:164)
      at $Proxy24.(Unknown Source)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruct
      orAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingC
      onstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
      at java.lang.reflect.Proxy.newProxyInstance(Proxy.java:588)
      at org.jboss.mx.util.MBeanProxyExt.create(MBeanProxyExt.java:345)
      at org.jboss.system.ServiceConfigurator.configure(ServiceConfigurator.ja
      va:357)
      at org.jboss.system.ServiceConfigurator.internalInstall(ServiceConfigura
      tor.java:442)
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java
      :153)
      at org.jboss.system.ServiceController.install(ServiceController.java:215
      )
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)