0 Replies Latest reply on May 12, 2006 6:58 PM by Leonard Sitongia

    2.4 ALPHA: works with Hypersonic, not with PostgreSQL 8.0

    Leonard Sitongia Newbie

      ALPHA works with the default configuration. I downloaded the bundle with the AS.

      I'm trying this under PostgreSQL 8.0.3, on Linux.

      server log shows and error starting up (I'll show what I think are relevant lines):

      2006-05-12 16:20:07,932 DEBUG [org.jboss.system.ServiceConfigurator] HomeDir set to /opt/jboss/server/default/data/portal/cms/conf in portal:service=CMS
      2006-05-12 16:20:07,945 DEBUG [org.jboss.system.ServiceConfigurator] Config set to [Repository: null] in portal:service=CMS
      
      2006-05-12 16:20:10,820 DEBUG [org.jboss.system.ServiceController] starting service portal:service=CMS
      
      2006-05-12 16:20:46,724 DEBUG [org.jboss.portal.cms.impl.jcr.JCRCMS] Starting failed portal:service=CMS
      javax.jcr.RepositoryException: failed to load persisted repository state: null: null
       at org.apache.jackrabbit.core.RepositoryImpl.loadRootNodeUUID(RepositoryImpl.java:379)
       at org.apache.jackrabbit.core.RepositoryImpl.<init>(RepositoryImpl.java:203)
      
      Caused by: java.lang.NullPointerException
       at org.postgresql.largeobject.BlobInputStream.close(BlobInputStream.java:115)
       at sun.nio.cs.StreamDecoder$CharsetSD.implClose(StreamDecoder.java:505)
       at sun.nio.cs.StreamDecoder.close(StreamDecoder.java:198)
       at java.io.InputStreamReader.close(InputStreamReader.java:187)
       at org.apache.jackrabbit.core.RepositoryImpl.loadRootNodeUUID(RepositoryImpl.java:370)
      


      Many of the tables are created in the PostgreSQL database.

      Later, when I open a page to the portal, I get an error related to the content of a portlet, and the CMS portlet is missing:

      2006-05-12 16:27:13,433 DEBUG [org.hibernate.loader.Loader] done loading collection
      2006-05-12 16:27:13,436 ERROR [org.jboss.portal.core.portlet.cms.CMSPortlet] The portlet threw an exception
      java.lang.RuntimeException: java.lang.NullPointerException
       at org.jboss.portal.cms.impl.jcr.JCRCMS.execute(JCRCMS.java:379)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      
      Caused by: java.lang.NullPointerException
       at org.jboss.portal.cms.impl.jcr.JCRCMS.execute(JCRCMS.java:375)
       ... 250 more
      2006-05-12 16:27:13,442 ERROR [org.jboss.portal.core.command.ControllerCommand] Portlet default.default.CMSPortletWindow got the following error
      java.lang.RuntimeException: java.lang.NullPointerException
       at org.jboss.portal.cms.impl.jcr.JCRCMS.execute(JCRCMS.java:379)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      


      Of course, this is alpha, and I probably shouldn't bother because the data model is probably going to change.

      Thanks,
      ==Leonard