1 Reply Latest reply on Jul 26, 2006 7:53 AM by Ryszard Kozmik

    JBoss Forum 2.2.1 SP3 Error

    Alexander Grünewald Newbie

      Hello Developers,

      I have just downloaded JBoss Portal (file: jboss-portal-2.2.1-SP3-bundled.zip) and JBoss Portal Forums (file: jboss-forums-2.2.1-SP3.zip). Then i installed JBoss Portal on a linux box using following commands:

      unzip jboss-portal-2.2.1-SP3-bundled.zip
      cd jboss-portal-2.2.1-SP3-bundled/
      chmod u+x bin/*.sh
      bin/run.sh
      


      Then i deployed Forums Portlet using the following commands:

      mkdir tmp
      unzip jboss-forums-2.2.1-SP3.zip -d tmp
      cp -r tmp/portal-forums.ear/portal-forums.war jboss-portal-2.2.1-SP3-bundled/server/default/deploy/
      rm -r tmp
      


      and the server logs this error message:

      13:28:20,489 ERROR [MainDeployer] Could not create deployment: file:/home/gruenewa/jboss-portal-2.2.1-SP3-bundled/server/default/deploy/portal-forums.war/
      org.jboss.ws.WSException: java.lang.ClassNotFoundException: org.jboss.portlet.forums.servlet.DownloadAttachmentsServlet
       at org.jboss.ws.server.WebServiceDeployerJSE.isWebserviceDeployment(WebServiceDeployerJSE.java:161)
       at org.jboss.ws.server.WebServiceDeployer.create(WebServiceDeployer.java:101)
       at org.jboss.ws.server.WebServiceDeployerJSE.create(WebServiceDeployerJSE.java:66)
       at org.jboss.deployment.SubDeployerInterceptorSupport$XMBeanInterceptor.create(SubDeployerInterceptorSupport.java:180)
       at org.jboss.deployment.SubDeployerInterceptor.invoke(SubDeployerInterceptor.java:91)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
       at $Proxy87.create(Unknown Source)
       at org.jboss.deployment.MainDeployer.create(MainDeployer.java:953)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:807)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:771)
       at sun.reflect.GeneratedMethodAccessor77.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
       at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
       at $Proxy8.deploy(Unknown Source)
       at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:421)
       at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:634)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:263)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:274)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:225)
      Caused by: java.lang.ClassNotFoundException: org.jboss.portlet.forums.servlet.DownloadAttachmentsServlet
       at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
       at java.security.AccessController.doPrivileged(Native Method)
       at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
       at org.jboss.ws.server.WebServiceDeployerJSE.isWebserviceDeployment(WebServiceDeployerJSE.java:151)
       ... 30 more
      


      Am i doing something wrong or is there a bug in the Forums Portlet?

      Thanks,
      Alexander