5 Replies Latest reply on Aug 10, 2006 5:55 PM by bmhardy

    Portal 2.4 with JBoss AS 4.0.4.GA plus ejb3

    bmhardy Newbie

      Can anyone point me in the direction of some installation instructions for Portal 2.4 with JBoss AS 4.0.4.GA plus EJB3. I tried adding the ejb3 package with the portal AS install bundle. It didn't work, the ejb3 install instructions described jar files that were not in the package so I didn't trust the instructions. I tried to install the portal binary on a working version of JBoss AS 4.0.4.GA with eJB3 installed using the installer. It didn't work. I read that in order to install the Portal binary with the AS, you must use the zipped version of AS rather than the installer. I haven't been able to configure EJB3 with that version of the AS. I am suspect since the instructions seem out of synce since they mention jar files not in the EJB3 package. Can anyone point me to some valid instructions? Thanks Brian

        • 1. Re: Portal 2.4 with JBoss AS 4.0.4.GA plus ejb3
          bmhardy Newbie

          I installed JBoss 4.0.4.GA zipped version. I was able to install the EJB3 package. version 8 didn't seem to work, but R6 did. I saw errors when I tried to install the portal binary version on the app server after EJB3 was installed.

          • 2. Re: Portal 2.4 with JBoss AS 4.0.4.GA plus ejb3
            bmhardy Newbie

            I thought I successfully deployed jboss portal 2.4.0 CR3 to Jboss AS 4.0.4.GA zipped version, but I can't seem to do it again. When I drop the portal sar file into the default deploy directory I get the following error:
            14:16:15,907 ERROR [MainDeployer] Could not initialise deployment: file:/V:/jboss-4.0.4.GA/server/default/deploy/jboss-portal.sar/
            org.jboss.deployment.DeploymentException: Failed to find META-INF/jboss-service.xml for archive jboss-portal.sar
            at org.jboss.deployment.SARDeployer.parseDocument(SARDeployer.java:616)
            at org.jboss.deployment.SARDeployer.init(SARDeployer.java:181)
            at org.jboss.deployment.MainDeployer.init(MainDeployer.java:861)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:798)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:771)
            at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
            at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
            at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
            at $Proxy8.deploy(Unknown Source)
            at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:421)
            at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:634)
            at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:263)
            at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:274)
            at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:225)
            14:16:31,095 WARN [MainDeployer] undeploy 'file:/V:/jboss-4.0.4.GA/server/default/deploy/jboss-portal.sar/' : package not deployed

            Any idea why?

            • 3. Re: Portal 2.4 with JBoss AS 4.0.4.GA plus ejb3
              bmhardy Newbie

              I found the JEMS-INSTALLER.1.2.0.BETA at http://prdownloads.sourceforge.net/jboss.

              This installer allowed me to get JBoss AS 4.0.4.GA with EJB3 and JBoss Portal 2.4.0.

              Run the installer with a version of 1.4 version of java since jdk 5 doesn't work with this installer. You can most likely download the jar in your browser and run it fine from there (Under firefox say Open With and use the built in Java, IE will just download and run it I think)

              Run the installer once and select ejb3 complete the install
              Run the installer again on the same location to overlay portal content. Select portal on the second install. Install your jdbc driver, create your datasource and build and run an ejb3 tutorial from RC8 to ensure all works.

              • 4. Re: Portal 2.4 with JBoss AS 4.0.4.GA plus ejb3
                Thomas Heute Master

                If you use the "portal" configuration of the JEMS installer 1.2.0 BETA http://prdownloads.sourceforge.net/jboss/jems-installer-1.2.0.BETA.jar?download

                java -jar ~/Download/jems-installer-1.2.0.BETA.jar

                You will get:
                "A JSR168 portal service on top of EJB3 Profile. Note, this is not a J2EE 1.4 compatible configuration."

                (PS: the installer works fine with a JDK 5)

                • 5. Re: Portal 2.4 with JBoss AS 4.0.4.GA plus ejb3
                  bmhardy Newbie

                  Good. that's exactly what I wanted - JSR 168

                  out of curiosity, what exactly do you mean by "Its not J2EE 1.4 compatible"?
                  Do you say that because it's using EJB3 which is becoming J2EE 5 compatible?

                  Thanks

                  PS when I ran the jems installer with jdk1.5 I saw an error like this:
                  Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException at javax.swing.text.html.CSS$FontSize.getValue(CSS.java:1672)

                  Jdk1.4 worked fine.