2 Replies Latest reply on Aug 21, 2006 11:41 AM by Peter Johnson

    Setting the content of the CMS Portlet Through the Managemen

    Danny Thornton Novice

      I want to use the Management Portlet to create several instances of the CMSPortlet in different pages. I also want to be able to use the Management Portlet to set the content of the CMSPortlets.

      I tried using the Management portlet to set the property indexpage for the CMSPortlet instance but this had no affect.

      Anyone know how to do this?

      Danny

        • 1. Re: Setting the content of the CMS Portlet Through the Manag
          Peter Johnson Master

          The first thing to do is create another instance of the CMS portlet. Do this from the Management Portlet, click on the Portlet link on the top row of the window. Scroll the list of portlet until you see local.portal.CMSPortlet. Click on that and then to the right type is a name for the new instance and click Create Instance.

          Next, adjust the default page for the new instance. Click on the Instances link in the top row (this step is not really necessary because when you create a new instance the window automatically switches to this view). Scroll the list to the new instance, it will be at the end of the list. When you see the new instance, click on the Id. To the right, click the icon showing a pencil over a piece of paper on the indexPage. Replace the current index page value (/default/index.html) with the desired page (I tried /default/project.html this time) and click the Update button.

          Finally, place the new instance on a page. Click on the Portal link in the top row. Expand the tree view until the desired page is showing, and add the new instance to the page. Then go view the page (you might have to log out first), the new content should show, and the old CMS portlet should still have the old content.

          • 2. Re: Setting the content of the CMS Portlet Through the Manag
            Peter Johnson Master

            Oh, you didn't mention which version of the portal you were using, so I assume 2.4.