2 Replies Latest reply on Sep 22, 2006 8:31 AM by Denis Marzadro

    How use UsersRoleLoginModule

    Denis Marzadro Novice

      Hi all,

      I have installed the portal 2.4.0 and i'm tring to simply use the UsersRolesLoginModule to log in the portal. The users not included into my users.properties and roles.properties files correctly cause a login failed error, but if i try to use one of the valid user i alwais recieve the error "HTTP Status 403 - Access to the requested resource has been denied"

      I tried lots of configurations, in the last one i changed login-config.xml inserting the section:

      <application-policy name = "myAuthentication">

      <login-module code = "org.jboss.security.auth.spi.UsersRolesLoginModule"
      flag = "required" >
      <module-option name="usersProperties">props/users.properties</module-option>
      <module-option name="rolesProperties">props/roles.properties</module-option>
      </login-module>

      </application-policy>

      and deploy\jboss-portal.sar\portal-server.war\WEB-INF\jboss-web.xml changing secutiry-domain with this:
      <security-domain>java:jaas/myAuthentication</security-domain>

      My two properties are both under default\conf\props folder and are very simple:
      users.properties contains:
      userx=passuserx
      usery=passusery
      roles.properties contains:
      userx=Admin
      usery=User

      i think nothing more have to be changed, someone can tell me if i'm forgetting to do something?
      thanks in advance