0 Replies Latest reply on Oct 3, 2006 2:23 AM by Vecchio Fabrizio

    Unable to deploy ajax4jsf portlet

    Vecchio Fabrizio Newbie

      Hi,
      i'm writing a portlet that use ajax4jsf library, but i have some problems during deployment phase. First i've tried to add the following to web.xml of my portlet :

       <filter>
       <display-name>Ajax4jsf Filter</display-name>
       <filter-name>ajax4jsf</filter-name>
       <filter-class>org.ajax4jsf.Filter</filter-class>
       </filter>
      
       <filter-mapping>
       <filter-name>ajax4jsf</filter-name>
       <servlet-name>Faces Servlet</servlet-name>
       <dispatcher>REQUEST</dispatcher>
       <dispatcher>FORWARD</dispatcher>
       <dispatcher>INCLUDE</dispatcher>
       </filter-mapping>
      


      but i've go an exception :
      ava.lang.IllegalStateException: No Factories configured for this Application - typically this is because a context listener is not setup in your web.xml.
      A typical config looks like this;
      <listener>
       <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
      </listener>
      
       at javax.faces.FactoryFinder.getFactory(FactoryFinder.java:84)
       at org.ajax4jsf.framework.resource.InternetResourceService.init(InternetResourceService.java:58)
       at org.ajax4jsf.framework.ajax.xmlfilter.BaseFilter.init(BaseFilter.java:121)
       at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:223)
       at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:304)
       at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:77)
       at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3600)
      ...
      ...
      
      


      Then i've tried to specify full configuration of myfaces in my web.xml but i've got the same exception.
      I've tried to use the portlet as a standalone web application and when i have deployed in jboss it works!
      Next i make the same but in the web.xml of portal-core.war but return to have the same exception.
      There is a way to have this working on a portlet ?
      Thanks to all