1 Reply Latest reply on Oct 17, 2006 10:31 AM by mmontoni

    portlet proxy setting

    cpage cpage Novice

      hi,

      i work behind a proxy.
      i would like to make the weather portlet and rss portlet work.

      i try to add param proxyhost and proxyport without success.

      thanks


      11:52:52,396 ERROR [NewsPortlet] Fatal Error reading/parsing XML Source.
      java.net.ConnectException: Connection timed out: connect
       at java.net.PlainSocketImpl.socketConnect(Native Method)
       at java.net.PlainSocketImpl.doConnect(Unknown Source)
       at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
       at java.net.PlainSocketImpl.connect(Unknown Source)
       at java.net.Socket.connect(Unknown Source)
       at java.net.Socket.connect(Unknown Source)
       at sun.net.NetworkClient.doConnect(Unknown Source)
       at sun.net.www.http.HttpClient.openServer(Unknown Source)
       at sun.net.www.http.HttpClient.openServer(Unknown Source)
       at sun.net.www.http.HttpClient.<init>(Unknown Source)
       at sun.net.www.http.HttpClient.New(Unknown Source)
       at sun.net.www.http.HttpClient.New(Unknown Source)




        • 1. Re: portlet proxy setting
          mmontoni Newbie

          Are you using JBoss AS?

          If so, you need to change in your bin\run.bat the JAVA_OPTS like this:

          set JAVA_OPTS=%JAVA_OPTS% -Dhttp.proxyHost=x.xx.xx.xx -Dhttp.proxyPort=80 -DproxySet=true
          


          Also you can try adding in your portlet.xml the following code:

           <init-param>
           <name>proxy</name>
           <value>x.xx.xx.xx</value>
           </init-param>
           <init-param>
           <name>proxyport</name>
           <value>80</value>
           </init-param>
          
          


          --Mariella.