2 Replies Latest reply on Sep 20, 2008 3:48 AM by Nicolas Feybesse

    OutputLink don't always work aftter ReRender

    Nicolas Feybesse Newbie

      The second outputlink of this test case don't work after reRender.

      It is a big problem for me because I need a text with an icon image to be clickable.

      Here is the code :

      
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml"
       xmlns:h="http://java.sun.com/jsf/html"
       xmlns:f="http://java.sun.com/jsf/core"
       xmlns:a="http://richfaces.org/a4j"
       xmlns:c="http://java.sun.com/jstl/core"
       xmlns:rich="http://richfaces.org/rich">
      
      <body>
      <f:view>
      
       <rich:panel id="panel">
      
       <h:outputLink value="http://www.genericsystem.com">
       <h:outputText value="TEST OK" />
       </h:outputLink>
      
       <h:outputLink value="http://www.genericsystem.com">
       <h:panelGrid>
       <h:outputText value="A Graphic Image Here" />
       <h:outputText value="TEST KO" />
       </h:panelGrid>
       </h:outputLink>
      
       <h:form>
       <a:commandButton value="test" reRender="panel" />
       </h:form>
      
       </rich:panel>
      
      </f:view>
      
      </body>
      


      It seems that the problem is the "h:panelgrid" into the outputlink.
      Same problem with a "s:div" into the outputlink.

      Could you have a look at this, and tell me if it is really a bug and if it has a chance to be patched ?

      RICHFACES 3.2.2.GA, JSF1.2_09,Facelet 1.1.15B1,JBOSS 4.2.3.GA, SEAM 2.1Snapshot

      Thanks in advance