2 Replies Latest reply on Mar 21, 2007 1:14 PM by Kev Roast

    Deploying MyFaces 1.1.5 portlet to JBossPortal2.4.1

    Kev Roast Newbie

      Hi,

      I'm attempting to deploy a MyFaces 1.1.5 based portlet to JBossPortal2.4.1 (bundled with JBossAS) - i'm getting a long stream of exception from MyFaces, on the lines of:

      11:36:33,909 ERROR [FacesConfigurator] failed to configure class org.apache.myfaces.renderkit.html.ext.HtmlRadioRenderer
      java.lang.ClassCastException: org.apache.myfaces.renderkit.html.ext.HtmlRadioRenderer
       at org.apache.myfaces.config.FacesConfigurator.configureRenderKits(FacesConfigurator.java:754)
       at org.apache.myfaces.config.FacesConfigurator.configure(FacesConfigurator.java:149)
       at org.apache.myfaces.portlet.MyFacesGenericPortlet.initMyFaces(MyFacesGenericPortlet.java:210)
       at org.apache.myfaces.portlet.MyFacesGenericPortlet.init(MyFacesGenericPortlet.java:128)
       at javax.portlet.GenericPortlet.init(GenericPortlet.java:270)
       at org.jboss.portal.portlet.container.PortletContainer.initPortlet(PortletContainer.java:387)
      


      an exception for each MyFaces component.

      I've tried "upgrading" the portal to MyFaces 1.1.5 (by simply overwriting the myfaces api/impl Jar in the tomcat.sar jsflibs folder with the newer ones). but it doesn't seem to help.

      Any ideas on how to solve this - does my application need to be compiled against MyFaces 1.1.4 - the same version as in the original bundled tomcat jsflibs?

      Thanks,

      Kevin