0 Replies Latest reply on Aug 16, 2007 5:56 PM by Lucas de Oliveira

    encoding issues on portal 2.6

    Lucas de Oliveira Newbie

      Hi there!
      We just moved from portal 2.4 to 2.6 and now everytime. On portal 2.4 some jsp pages displayed weird characters sometimes (like a white'?' on a black square - a.k.a encoding issues) but the page was displayed anyway. Now on 2.6 it simply crashes and throws the following Exception:

      16:53:37,375 ERROR [STDERR] java.io.CharConversionException: Not an ISO 8859-1 character: ?
      16:53:37,376 ERROR [STDERR] at javax.servlet.ServletOutputStream.print(ServletOutputStream.java:89)
      16:53:37,376 ERROR [STDERR] at javax.servlet.ServletOutputStream.println(ServletOutputStream.java:242)
      16:53:37,376 ERROR [STDERR] at com.zAgile.zOntologyNavigator.servlets.zOntologyNavigatorServlet.printOnClient(zOntologyNavigatorServlet.java:88)
      16:53:37,376 ERROR [STDERR] at com.zAgile.zOntologyNavigator.servlets.zOntologyNavigatorServlet.doPost(zOntologyNavigatorServlet.java:79)
      16:53:37,376 ERROR [STDERR] at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
      16:53:37,376 ERROR [STDERR] at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      16:53:37,376 ERROR [STDERR] at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      16:53:37,376 ERROR [STDERR] at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
      16:53:37,376 ERROR [STDERR] at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
      16:53:37,376 ERROR [STDERR] at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      16:53:37,376 ERROR [STDERR] at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:241)
      16:53:37,377 ERROR [STDERR] at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
      16:53:37,377 ERROR [STDERR] at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:580)
      16:53:37,377 ERROR [STDERR] at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      16:53:37,377 ERROR [STDERR] at java.lang.Thread.run(Thread.java:595)
      


      We tryed setting tomcat's enconding to UTF-8 but it didn't work.
      JSP's and servlets reponses and requests are all setting the enconding.
      Any clue how to solve that?

      thanks in advance!