3 Replies Latest reply on Jun 13, 2008 11:06 AM by ram sundaram

    JBoss Portal 2.6.1 bundled - null pointer exception

    Vicente Hortal Puentes Newbie

      Hello,

      I am an absolute beginner in this field. I could not find any report on a similar problem so here I go.

      I deploy and run the bundled version of the JBoss Portal 2.6.1 GA (without any changes) on Windows XP Professional (spanish language), and everything mentioned in the quickstart guide seems to work as expected, with the exception that when I click on Project Information / JBoss Portal Project (in the content area, pointing to http://localhost:8080/portal/content/default/project.html) I get the following stacktrace:

      java.lang.NullPointerException
       at org.jboss.portal.core.cms.ui.CMSPortlet.doView(CMSPortlet.java:235)
       at javax.portlet.GenericPortlet.doDispatch(GenericPortlet.java:133)
       at org.jboss.portal.core.cms.ui.CMSPortlet.doDispatch(CMSPortlet.java:313)
       at javax.portlet.GenericPortlet.render(GenericPortlet.java:306)
       at org.jboss.portal.portlet.impl.jsr168.PortletContainerImpl.invokeRender(PortletContainerImpl.java:483)
       at org.jboss.portal.portlet.impl.jsr168.PortletContainerImpl.dispatch(PortletContainerImpl.java:405)
       at org.jboss.portal.portlet.container.PortletContainerInvoker$1.invoke(PortletContainerInvoker.java:86)
      ...


      This happens only the first time in the session, when hitting the back button and clicking again on the link the right content is shown. The same happens when I upload and link to the quickstart.zip as explained in the guide (first click null pointer exception, then the link works).

      This sounds to me like a problem with the cache, and I can see indeed in the log the following entry (previous to the stack trace):
      WARN [org.jboss.web.tomcat.service.jasper.TagLibCache] Internal error: File /WEB-INF/web.xml not found


      I'll be grateful for any hints on what the problem is. Thanks in advance.

      V. Hortal