3 Replies Latest reply on Dec 2, 2007 7:49 PM by Wesley Hales

    Newbie Portal Question

    David Welford-Costelloe Newbie

      Hi,
      I have my portal running on my www.domain.com
      Using the below configuration I am able to see the:

      JBoss Application Server when a request is sent to www.domain.com. Instead I would like to see the default portal show up instead of the application server.

      Here are my Configurations
      ==================
      httpd.conf:

      LoadModule jk_module /usr/lib/apache2/modules/mod_jk.so
      
      JkWorkersFile /etc/apache2/workers.properties
      JkShmFile /var/log/httpd/mod_jk.shm
      JkLogFile /etc/apache2/logs/mod_jk.log
      JkLogLevel info
      JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
      
      



      workers.properties
      =============
      worker.list=worker1
      worker.worker1.type=ajp13
      worker.worker1.host=localhost
      worker.worker1.port=8009
      
      # Define Node1
      # modify the host as your host IP or DNS name.
      worker.node1.port=8009
      worker.node1.host=node1.welford-costelloe.com
      worker.node1.type=ajp13
      worker.node1.lbfactor=1
      # worker.node1.connection_pool_size=10 (1)
      
      # Define Node2
      # modify the host as your host IP or DNS name.
      #worker.node2.port=8009
      #worker.node2.host= node2.mydomain.com
      #worker.node2.type=ajp13
      #worker.node2.lbfactor=1
      # worker.node1.connection_pool_size=10 (1)
      
      # Load-balancing behaviour
      worker.loadbalancer.type=lb
      worker.loadbalancer.balance_workers=node1
      #,node2
      
      # Status worker for managing load balancer
      worker.status.type=status
      

      Apache2 Default
      ===========
      NameVirtualHost *:80
      <VirtualHost *:80>
      ServerAdmin webmaster@localhost
      ServerName welford-costelloe.com
      DocumentRoot /www/www.welford-costelloe.com/
      
      Options FollowSymLinks
      #AllowOverride None
      
      <Directory /www/www.welford-costelloe.com/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
      # in /apache2-default/, but still have / go to the right place
      #RedirectMatch ^/$ /apache2-default/
      </Directory>
      ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
      <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
      </Directory>
      
      ServerSignature On
      LogLevel warn
      
      ErrorLog /var/log/apache2/www.welford-costelloe.com-error_log
      TransferLog logs/www.welford-costelloe.com-access_log
      
      JkMount /* worker1
      
      #
      # allow from all
      #
      Alias /doc/ "/usr/share/doc/"
      <Directory "/usr/share/doc/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order deny,allow
      Deny from all
      Allow from 127.0.0.0/255.0.0.0 ::1/128
      allow from all
      </Directory>
      
      </VirtualHost>
      
      


      If anyone could help it would be greatly appreciated.

      Thanks