0 Replies Latest reply on Feb 5, 2008 7:53 AM by Venkata Apparao

    A typical problem with dashboard and editdashboard in cluste

    Venkata Apparao Newbie

      Hi

      We are facing a typical issue with dashboard link and its funtionality in clustered version of jboss portal.

      We are using jboss-portal 2.6.1 and application server is Jboss 4.05 GA.
      When we form a cluster of 3 nodes the dashboard link and its functionality is not happening properly. for example when i click on dashboard link it is immediatly throwing 500 error, after few refreshes it is displaying properly. Then when clicked on edit dashboard link and create a new page, it is not reflecting the new page name in the select box of edit page and after few refreshes it is listing, then when we select perticular instance for that page it is getting refreshed and showing default page. This is the behaviour that is happening.

      But when a single node is there all the functionality is happening properly.

      I expected this behaviour mainly due to the cache and updated my server jboss cache to jboss-cache 1.4.1 SP1 and jgroups.jar that comes with the jboss-cache 1.4.1 SP1 distribution. But the problem was not resolved.

      What would be the problem? and what is the solution to rectify this problem?

      What version of the cache that is required to use?
      Once again i am listing my configurations

      1) Jboss-portal 2.6.1 ha.sar
      2) Jboss 4.05 GA
      3) jboss-cache.jar and jgroups.jar from jboss-cache 1.4.1 SP1 distribution
      4) 3 node cluster, data base is oracle 10 g
      5) Rest of the other configurations like hibernate every thing are default that comes with the server jboss 4.05 GA
      6) java 1.5

      Thanks in advance for any help.