1 Reply Latest reply on Oct 9, 2008 5:52 AM by Kto ToTaki

    IE6,7 JS undefined Error

    Kto ToTaki Newbie

      Environment: Tomcat 6.0.14, last version of RF 3.3.0-SNAPSHOT(api,impl) and richfaces-ui-3.3.0-20081008.041111-29.jar
      Client : IE 6 or 7 (work on IE8!)

      Rendering a page including <rich:suggestionbox or <rich:tooltip gives an JS error :
      'ToolTip' is undefined ,pointing to source code new ToolTip(...)
      The same situations concern some other tags like suggestionbox. But other tags works!

      It's looks like js code are not downloaded to the browser? Or not send from the server.

      Header includes :

      <script type='text/javascript' src='/ProductCatalogAdmin/a4j/g/3_3_0-SNAPSHOT/org/ajax4jsf/framework.pack.js.faces'></script>
      <script type='text/javascript' src='/ProductCatalogAdmin/a4j/g/3_3_0-SNAPSHOT/org/richfaces/ui.pack.js.faces'></script>
      
      where ToolTip object should be defined.


      Loading strategy is defined in web.xml as:
      <context-param>
       <param-name>org.richfaces.LoadScriptStrategy</param-name>
       <param-value>ALL</param-value>
       </context-param>
       <context-param>
       <param-name>org.ajax4jsf.COMPRESS_SCRIPT</param-name>
       <param-value>false</param-value>
       </context-param>
       <context-param>
       <param-name>org.richfaces.LoadStyleStrategy</param-name>
       <param-value>ALL</param-value>
       </context-param>
       <context-param>
       <param-name>org.ajax4jsf.DEFAULT_EXPIRE</param-name>
       <param-value>86401</param-value>
       </context-param>
      
      

      Any ideas what can course such error ?



        • 1. Re: IE6,7 JS undefined Error
          Kto ToTaki Newbie

          He, my again

          I found the reason for JS error in IE 6 and 7 :
          Using 3.3.0-SNAPSHOT gives a error, but using 3.2.2.GA works fine !

          Tested different 3.3.0-SNAPSHOT versions, (from richfaces-ui-3.3.0-20080919.045725-12.jar to richfaces-ui-3.3.0-20081009.041318-30.jar, with corresponding richfaces-impl-3.3.0-SNAPSHOT.jar/richfaces-api-3.3.0-SNAPSHOT.jar)
          and all produce JS error.

          I hope, it could be corrected before official 3.3.0 ships out.