1 Reply Latest reply on Aug 7, 2008 6:21 AM by gressho

    JBP won't show instances created by portlet-instances.xml

    gressho Newbie

      Hello,

      I'm observing a weird behaviour in JBP 2.6.6. Given the following portlet-instances.xml (which worked perfectly for JBP 2.6.4 and JBP 2.6.5):

      <?xml version="1.0" encoding="UTF-8"?>
      
      <!--
       Document : portlet-instances.xml
       Created on : 12. November 2007, 16:59
       Author : gressho
       Description:
       Purpose of the document follows.
      -->
      
      <!DOCTYPE deployments PUBLIC '-//JBoss Portal//DTD Portlet Instances 2.6//EN' 'http://www.jboss.org/portal/dtd/portlet-instances_2_6.dtd'>
      <deployments>
      
       <deployment>
       <if-exists>overwrite</if-exists>
       <instance>
       <instance-id>SubjectManagementInstance</instance-id>
       <portlet-ref>SubjectManagementPortlet</portlet-ref>
       <security-constraint>
       <policy-permission>
       <action-name>view</action-name>
       <role-name>User</role-name>
       </policy-permission>
       </security-constraint>
       </instance>
       </deployment>
       <deployment>
       <if-exists>overwrite</if-exists>
       <instance>
       <instance-id>LibraryManagementInstance</instance-id>
       <portlet-ref>LibraryManagementPortlet</portlet-ref>
       <security-constraint>
       <policy-permission>
       <action-name>view</action-name>
       <role-name>u7dbdi</role-name>
       </policy-permission>
       </security-constraint>
       </instance>
       </deployment>
       <deployment>
       <if-exists>overwrite</if-exists>
       <instance>
       <instance-id>SearchindexManagementInstance</instance-id>
       <portlet-ref>SearchindexManagementPortlet</portlet-ref>
       <security-constraint>
       <policy-permission>
       <action-name>view</action-name>
       <role-name>User</role-name>
       </policy-permission>
       </security-constraint>
       </instance>
       </deployment>
       <deployment>
       <if-exists>overwrite</if-exists>
       <instance>
       <instance-id>SystemManagementInstance</instance-id>
       <portlet-ref>SystemManagementPortlet</portlet-ref>
       <security-constraint>
       <policy-permission>
       <action-name>view</action-name>
       <role-name>u7sysadmin</role-name>
       </policy-permission>
       <policy-permission>
       <action-name>view</action-name>
       <role-name>u7sys</role-name>
       </policy-permission>
       </security-constraint>
       </instance>
       </deployment>
      
      </deployments>
      


      The instances are created and I can see them in the database:


      jbossportal266=# select * from jbp_instance;
      pk | id | portlet_ref | modifiable | ser_state
      ----+----------------------------------+-----------------------------------------------------+------------+-----------
      1 | IdentityUserPortletInstance | local._1 | t |
      3 | IdentityAdminPortletInstance | local._4 | t |
      5 | GoogleWidgetPortletInstance | local./portal-widget.GoogleWidgetPortlet | f |
      7 | WSRPConfigurationPortletInstance | local./portal-wsrp-admin.WSRPConfigurationPortlet | f |
      9 | CMSPortletInstance | local._6 | t |
      11 | CMSAdminPortletInstance | local./portal-cms.CMSAdminPortlet | f |
      13 | NetvibesWidgetPortletInstance | local./portal-widget-netvibes.NetvibesWidgetPortlet | f |
      15 | UserPortletInstance | local.portal.UserPortlet | f |
      17 | RolePortletInstance | local.portal.RolePortlet | f |
      19 | CatalogPortletInstance | local.portal.CatalogPortlet | f |
      21 | PortletContentEditorInstance | local.portal.PortletContentEditorPortlet | f |
      24 | AdminPortletInstance | local./portal-admin.AdminPortlet | f |
      26 | DashboardConfigPortletInstance | local./portal-admin.DashboardConfigPortlet | f |
      28 | SubjectManagementInstance | local./ulbapps.SubjectManagementPortlet | f |
      30 | LibraryManagementInstance | local./ulbapps.LibraryManagementPortlet | f |
      32 | SearchindexManagementInstance | local./ulbapps.SearchindexManagementPortlet | f |
      34 | SystemManagementInstance | local./ulbapps.SystemManagementPortlet | f |


      In the admin portlet I can't see anything! The corresponding *-object.xml creates windows
      and pages based on the definitions but they are empty.
      BTW: I can't see PortletContentEditorInstance and some others in database as well!

      Best wishes

      Werner