9 Replies Latest reply on Oct 14, 2008 4:27 AM by halil agin

    Quick Start - Quick Fail

    Umur YILMAZ Newbie

      I have used tomcat and I know most of the difficulties about Java and enviroment problems.

      After reading this tutorial (I am sure people are putting lots of efforts on creating these documentations) I gave it a shot.

      http://docs.jboss.com/jbportal/v2.6.6/quickstartuser/html_single/

      On Windows XP with Java 1.5.0_14 I got several lines of error messages. I do not know how to start as I am not familiar with JBoss Application Server environment. If I fail to run a bundle of JBoss Ap Serv and Portal 2.6.6, I am sure many people failed too.

      I believe people should try more on making JBoss environment more error-proof because IT Specialists like we are, do not have unlimited time to go through all the JBoss Forums.

        • 1. Re: Quick Start - Quick Fail
          Thomas Heute Master

          What about mentioning the error you get ? You can make sure that it works for most people since it has been tested.

          • 2. Re: Quick Start - Quick Fail
            Umur YILMAZ Newbie

            Hi Thomas,

            sorry for my temper with the initial post. I was overstressed obviously..

            I really do not if it is the portal or the application server that fails. I get localhost:8080 fine but not /portal.

            console had many debug and error level messages. Some errors from jboss-portal-2.6.6.GA\server\default\log\server

            --------------------------------------

            2008-09-28 10:44:54,718 ERROR [org.jboss.deployment.MainDeployer] Could not create deployment: file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/jboss-portal.sar/portal-wsrp.sar/
            org.jboss.deployment.DeploymentException: TX TYPE was null for: Required; - nested throwable: (java.lang.RuntimeException: TX TYPE was null for: Required)

            2008-09-28 10:45:05,843 ERROR [STDERR] org.jboss.mx.util.MBeanProxyCreationException: Object name portal:service=ListenerRegistry not found: javax.management.InstanceNotFoundException: portal:service=ListenerRegistry is not registered.
            2008-09-28 10:45:05,843 ERROR [STDERR] at org.jboss.mx.util.JMXInvocationHandler.(JMXInvocationHandler.java:163)
            2008-09-28 10:45:05,843 ERROR [STDERR] at org.jboss.mx.util.MBeanProxy.get(MBeanProxy.java:90)


            2008-09-28 10:45:11,265 ERROR [org.jboss.deployment.MainDeployer] Could not create deployment: file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/portal-hsqldb-ds.xml
            org.jboss.deployment.DeploymentException: create operation failed for package file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/portal-hsqldb-ds.xml; - nested throwable: (javax.management.InstanceNotFoundException: portal:service=Hibernate,type=WSRPConsumer is not registered.)
            at org.jboss.deployment.SARDeployer.create(SARDeployer.java:280)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)


            2008-09-28 10:45:11,390 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] Incomplete Deployment listing:

            --- Incompletely deployed packages ---
            org.jboss.deployment.DeploymentInfo@403058eb { url=file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/jboss-portal.sar/portal-aop.xml }
            deployer: org.jboss.aop.deployment.AspectDeployer@694f12
            status: Created
            state: CREATED
            watch: file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/jboss-portal.sar/portal-aop.xml
            altDD: null
            lastDeployed: 1222587888687
            lastModified: 1222587888687
            mbeans:

            org.jboss.deployment.DeploymentInfo@d818c2dc { url=file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/jboss-portal.sar/portal-admin.sar/lib/portal-faces-loader-lib.jar }
            deployer: org.jboss.deployment.JARDeployer@b4e29b
            status: Created
            state: CREATED
            watch: file:/K:/Work/JBoss/jboss-portal-2.6.6.GA/server/default/deploy/jboss-portal.sar/portal-admin.sar/lib/portal-faces-loader-lib.jar
            altDD: null
            lastDeployed: 1222587888750
            lastModified: 1222587888718
            mbeans:
            .....

            2008-09-28 10:49:49,140 ERROR [org.jboss.portal.server.servlet.PortalServlet] Cannot get portal server
            org.jboss.mx.util.MBeanProxyCreationException: Object name portal:service=Server not found: javax.management.InstanceNotFoundException: portal:service=Server is not registered.
            at org.jboss.mx.util.JMXInvocationHandler.(JMXInvocationHandler.java:163)
            at org.jboss.mx.util.MBeanProxy.get(MBeanProxy.java:90)
            at org.jboss.mx.util.MBeanProxy.get(MBeanProxy.java:78)
            at

            • 3. Re: Quick Start - Quick Fail
              Thomas Heute Master

              Very weird...
              Could it be that the download got corrupted ?

              • 4. Re: Quick Start - Quick Fail
                Umur YILMAZ Newbie

                I tried 2.7.0CR1 and got the same error

                What is TX Type?

                maybe I already have some conflicting libraries in my classpath. Any ideas?

                • 5. Re: Quick Start - Quick Fail
                  Prabhat Jha Master

                  This is really weird. Are you installing portal on AS copy that you already had or you are using bundled distro? If former is the case, please download the bundled distro and see if you get the same error. For the later case, please check classpath etc.

                  We verify that bundled distro as well as simply portal zip start fine and we have not seen complaint from other users.

                  • 6. Re: Quick Start - Quick Fail
                    Umur YILMAZ Newbie

                    Actually that was the bundled distro, that was why I got annoyed at first.

                    I couldnt run the distro on my Laptop (Vista Business) and on my PC (Windows XP). Almost same errors. I suspect it is some configuration I had made with Java Libraries.

                    Same files work fine on my Linux box. I do not get it?! Anyways If I findout I post here to inform you.

                    Thanks.

                    • 7. Re: Quick Start - Quick Fail
                      Peter Johnson Master

                       

                      maybe I already have some conflicting libraries in my classpath


                      I hope that you have not set the CLASSPATH environment variable. That is a sure way to get into trouble. The run script will set everything you need. On my machines, the only Java-related env vars I have set are JAVA_HOME and various other "home" directories (e.g. ANT_HOME).

                      Another thing to check is that you do not any endorsed directories - JAR files therein could also cause issues.

                      One way to track down unwanted JAR files is to set the -verbose:class JVM option in the run script. This option will list each class loaded and the JAR file containing that class. The only JAR files you should see are rt.jar and those within JBOSS_HOME; if you see any others they are suspect.

                      • 8. Re: Quick Start - Quick Fail
                        halil agin Newbie

                        Hello;


                        I got the same exception and think i solve the problem.
                        I am using Turkish locale in my OS and Jboss AS has some problem with Turkish locale. I do not know which locale you use, but it seems that you are using the turkish locale (because your name is turkish)

                        I solve the problem by changing ./aspects/src/main/org/jboss/aspects/tx/TxInterceptorFactory.java file.

                        but after that, there occure one more problem, the reason of the problem is also turkish locale. The problem occurs in ./connector/src/main/org/jboss/resource/adapter/jdbc/WrappedResultSet.java


                        I am trying to reporting bugs, but interestingly i could not find a bug reporting screen in jira.jboss.org

                        If this forum help me to report bugs, i think you will solve your problem.

                        till bug reporting, you can reach me from halil.agin _at_ gmail.com
                        i prepared the reporting texts, and patched source files.


                        regards,


                        -halil agin.



                        i am trying to reporting