2 Replies Latest reply on Jan 25, 2009 10:33 PM by Wesley Hales

    Exception when deploying a project created by the JSF portle

    Axel Motyka Newbie

      I am trying to setup a JSF/Portlet for bundeled version of JBoss Portal 2.7.0 with the last JBoss Developer Studio 2.0.0 CR1 or the latest JBoss Tools and my own eclipse.
      But everytime i deploy the automatically created skeleton I get:

      13:50:49,718 INFO [TomcatDeployer] deploy, ctxPath=/JSFPortletApp, warUrl=.../deploy/JSFPortletApp.war/
      13:50:50,484 ERROR [[/JSFPortletApp]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener
      com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! org.apache.commons.digester.Digester
       at com.sun.faces.config.ConfigManager.initialize(ConfigManager.java:212)
       at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:195)
       at org.jboss.web.jsf.integration.config.JBossJSFConfigureListener.contextInitialized(JBossJSFConfigureListener.java:71)
       at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3856)
       at org.apache.catalina.core.StandardContext.start(StandardContext.java:4361)
       at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:790)
       at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:770)
       at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:553)


      What i did:
      1. Downloaded the actual bundled Portal 2.7.0 with JBoss 4.2.3
      2. Extracted files
      3. Installed eclipse-jee-ganymede-SR1-win32 with JBossTools 3.0 Beta1
      4. Installed JBoss Developer Studio 2.0.0.CR1
      5. Followed http://download.jboss.org/jbosstools/nightly-docs/en/jboss_portal_tools_ref_guide/html_single/index.html#jsf_portlet
      6. Deployed project as described
      7. Added libs to project (with these libs I dont get the missing class exception anymore):
      portletbridge-api-1.0.0.B5.jar
      portletbridge-impl-1.0.0.B5.jar
      richfaces-api-3.3.0.GA.jar
      richfaces-impl-3.3.0.GA.jar
      richfaces-ui-3.3.0.GA.jar

      When deploying to or starting Jboss i always get the exception!