1 Reply Latest reply on Mar 27, 2009 5:40 AM by Gabriel Muench

    Creating new theme and URLs getting prefixed with .war filen

    Richard Conner Newbie

      Environment:
      JBoss Portal version 2.6.7.GA [downloaded it]
      JBoss version 4.3.0.GA_CP03_EAP (build: SVNTag=JBPAPP_4_3_0_GA_CP03 date=200810241616)
      [no database used by portal - yet]

      OS: Linux 2.6.16.46-0.12-bigsmp (i386)

      The problem:

      I'm trying to add our own customized theme (based off a copy of industrial theme) to portal and created an ep-theme.war file containing:

      ep\portal_style.css
      ep\images\activeTab.gif
      ...snip...
      ep\images\remove.gif
      ep\images\view.gif
      WEB-INF\portal-themes.xml


      WEB-INF\portal-themes.xml contains:
      <themes>
       <theme>
       <name>EP</name>
       <link rel="stylesheet" id="main_css" href="/themes/ep/portal_style.css" type="text/css"/>
       <link rel="shortcut icon" href="/themes/ep/images/favicon.ico"/>
       </theme>
      </themes>


      ep\portal_style.css is identical to industrial with the following change:
      #logoName {
      /* Original Logo...*/
       background-image: url( images/EPLogo.gif );
      


      After dropping ep-theme.war in JBoss deploy directory, looking at the log files seems fine like with the exception that ThemeLink is creating or making links like "/ep-theme/themes/ep/..."

      And, after configuring the page to use the new "EP" theme, I get no logo, a whole lot of blank space with the login/admin nav links.

      Looking at the page source, I see that same "/ep-theme/" mangling of the URLs:
      ...
      <link rel="stylesheet" type="text/css" id="main_css" href="/ep-theme/themes/ep/portal_style.css" />
      <link rel="shortcut icon" href="/ep-theme/themes/ep/images/favicon.ico" />
      ...


      This seems to be similar to a prior jira entry: https://jira.jboss.org/jira/browse/JBPORTAL-1105 but that shows resolved as of 2.6.