5 Replies Latest reply on Apr 27, 2009 9:53 AM by Peter Johnson

    Unable to login to Jboss portal 2.7.2

    vikas kedia Newbie

      Hi All

      I have just installed Jboss Portal 2.7.2 along with JBoss AS 4.2.3. I am able to access the login page but I cannot login after that. I have tried the default logins admin:admin and user:user. But both of them do not seem to work. What can be the issue?
      My environment is
      Windows
      MySql 5

      thanks
      Vikas

        • 1. Re: Unable to login to Jboss portal 2.7.2
          Peter Johnson Master

          That should work.

          Look in the database and ensure that you have a jbpm_users table with two rows, with jbp_uname entries of 'admin' and 'user'. If you do not have that, then he database is not properly configured.

          • 2. Re: Unable to login to Jboss portal 2.7.2
            vikas kedia Newbie

            Hi Peter,

            Thanks for the reply. I looked in the database and there is no jbpm_users table though there is a jbp_users table and that is empty.
            But my database seems to be properly configured because these tables are getting created which means that portal is able to connect to the db. Can you suggest if something else might be wrong.

            thanks
            Vikas

            • 3. Re: Unable to login to Jboss portal 2.7.2
              Peter Johnson Master

              Sorry, the table name I gave was a typo - you have the correct table. Are all of the table empty, or do some of them have content? For example, in my database jbp_portal_mode has 12 rows, and jbp_portal_object has 29 rows (the number of rows you have might be different).

              The initial users are loaded from the file jboss-portal.sar/conf/hibernate/user/setup.txt. Check that file.

              In the log file, you should see entries like this:

              2009-03-25 16:18:36,663 DEBUG [org.hibernate.pretty.Printer] listing entities:
              2009-03-25 16:18:36,665 DEBUG [org.hibernate.pretty.Printer] org.jboss.portal.identity.db.HibernateRoleImpl{users=[org.jboss.portal.identity.db.HibernateUserImpl#4], name=User, displayName=Users, key=2}
              2009-03-25 16:18:36,665 DEBUG [org.hibernate.pretty.Printer] org.jboss.portal.identity.db.HibernateRoleImpl{users=[org.jboss.portal.identity.db.HibernateUserImpl#3], name=Admin, displayName=Administrators, key=1}
              2009-03-25 16:18:36,666 DEBUG [org.hibernate.pretty.Printer] org.jboss.portal.identity.db.HibernateUserImpl{dynamic=[], enabled=true, registrationDate=2009-03-25 16:18:36, viewRealEmail=true, roles=[org.jboss.portal.identity.db.HibernateRoleImpl#1], familyName=null, fakeEmail=null, userName=admin, realEmail=admin@portal.com, givenName=null, password=21232f297a57a5a743894a0e4a801fc3, key=3}
              2009-03-25 16:18:36,667 DEBUG [org.hibernate.pretty.Printer] org.jboss.portal.identity.db.HibernateUserImpl{dynamic=[], enabled=true, registrationDate=2009-03-25 16:18:36, viewRealEmail=true, roles=[org.jboss.portal.identity.db.HibernateRoleImpl#2], familyName=null, fakeEmail=null, userName=user, realEmail=user@portal.com, givenName=null, password=ee11cbb19052e40b07aac0ca060c23ee, key=4}


              • 4. Re: Unable to login to Jboss portal 2.7.2
                vikas kedia Newbie

                I figured out what was wrong? I was using an older mysql connector which pukes when you try to put 'true' in a field which is of type bit(1) which hibernate does when creating default users. I updated the connector and it started working.
                Thanks for the help!!

                • 5. Re: Unable to login to Jboss portal 2.7.2
                  Peter Johnson Master

                  I think you ran into this issue: http://www.jboss.org/community/docs/DOC-9120

                  That is such an old issue I completely forgot about it.