4 Replies Latest reply on Jan 31, 2005 5:40 PM by ryan.campbell

    Third party dependencies

    Charles Crouch Expert

      FYI

      Here is a list of third party dependencies I have identified so far the Admin Console.

      Struts related:
      struts.jar (version 1.2.6)
      commons-logging.jar (version 1.0.4)
      commons-beanutils.jar (version 1.7.0)
      commons-digester.jar (version 1.6)
      commons-fileupload.jar (version 1.0)
      commons-validator.jar (version 1.1.3)
      jakarta-oro.jar (version 2.0.8)
      antlr.jar (version 2.7.4)

      JSTL related:
      jstl.jar (version 1.1.2)
      standard.jar (version 1.1.2)

      Thanks

        • 1. Re: Third party dependencies
          ryan.campbell Expert

          There is an existing thirdparty/apache/struts directory which we can use. We need to remove extraneous artifacts and upgrade the ones that are there. It seems to be part of the "applications" module, but I can't find any documentation about this, so I assume it is obsolete?

          • 2. Re: Third party dependencies
            ryan.campbell Expert

            You are requesting commons-logging 1.0.4 which conflicts with the existing version of 1.0.3. I suggest we try staying with 1.0.3 unless it proves ibcompatible. Then we will have to look at moving all other components to 1.0.4. The differences are small between the two, but I prefer stability if we can have it.

            • 3. Re: Third party dependencies
              Charles Crouch Expert

              1.0.4 doesn't look like it contains anything which Struts/Admin Console should really need:

              http://jakarta.apache.org/commons/logging/commons-logging-1.0.4/RELEASE-NOTES.txt

              Lets try sticking with 1.0.3 and see if we run into problems.

              • 4. Re: Third party dependencies
                ryan.campbell Expert

                I plan to add the following files to thirdparty, and to jboss-head in CVSROOT/modules:

                /thirdparty/apache/commons/lib/commons-validator-1.1.3.jar
                /thirdparty/apache/oro/lib/jakarta-oro-2.0.8.jar
                /thirdparty/apache/oro/LICENSE
                /thirdparty/apache/struts/lib/struts-1.2.6.jar
                /thirdparty/apache/taglibs/lib/standard-1.1.2.jar
                /thirdparty/apache/taglibs/lib/jstl-1.1.2.jar
                /thirdparty/apache/taglibs/LICENSE
                /thirdparty/antlr/lib/antlr-2.7.4.jar
                /thirdparty/antlr/LICENSE

                I plan to update the following existing files to the requested versions as they do not seem to be used according to libraries.ent:

                /thirdparty/apache/commons/commons-beanutils.jar
                /thirdparty/apache/commons/commons-digester.jar

                commons-fileupload is at the requested version (1.0)

                I'll update /thirdparty/license/* as well.