0 Replies Latest reply on Jun 28, 2007 5:45 AM by Wojtek

    Compiling JBossPortal - problem with Eclipse

    Wojtek Newbie

      I have a problem with compiling JBossPortal in Eclipse.
      [echo] build.classes=C:\programy\eclipse\workspace\jboss-portal-2.0-commerce\core/output/classes
      [execmodules] 2007-06-28 11:22:49 xdoclet.XDocletMain start
      [execmodules] INFO: Running
      [execmodules] null
      [execmodules] ParameterImpl instances: 20
      [execmodules] MethodImpl instances: 4896
      [execmodules] ConstructorImpl instances: 599
      [execmodules] SimpleNode instances: 0
      [execmodules] SourceClass instances: 864
      [execmodules] XDoc instances: 364
      [execmodules] DefaultXTag instances: 765
      [execmodules] BinaryClass instances: 244
      [execmodules] UnknownClass instances: 420
      [execmodules] Total memory: 63
      [execmodules] Free memory: 0
      [execmodules] Try to increase heap size. Can be done by defining ANT_OPTS=-Xmx640m
      [execmodules] See the JDK tooldocs.
      [execmodules] INFO: Some classes refer to other classes that were not found among the sources or on the classpath.
      [execmodules] (Perhaps the referred class doesn't exist? Hasn't been generated yet?)
      [execmodules] The referring classes do not import any fully qualified classes matching these classes.
      [execmodules] However, since no packages are imported, xjavadoc has assumed that the referred classes
      [execmodules] belong to the same package as the referring class. The classes are:
      [execmodules] C:\programy\eclipse\workspace\jboss-portal-2.0-commerce\core\src\main\org\jboss\portal\core\portlet\cms\admin\security\AdminCMSModelContentProvider.java --> Job qualified to org.jboss.portal.core.portlet.cms.admin.security.Job
      [execmodules] C:\programy\eclipse\workspace\jboss-portal-2.0-commerce\core\src\main\org\jboss\portal\core\portlet\itera\WebDAVHelpers.java --> Job qualified to org.jboss.portal.core.portlet.itera.Job
      [execmodules] C:\programy\eclipse\workspace\jboss-portal-2.0-commerce\core\src\main\org\jboss\portal\core\portlet\itera\portlets\b2cuser\B2CuserPortlet.java --> Job qualified to org.jboss.portal.core.portlet.itera.portlets.b2cuser.Job
      [execmodules] C:\programy\eclipse\workspace\jboss-portal-2.0-commerce\core\src\main\org\jboss\portal\core\portlet\itera\portlets\content\ContentPortlet.java --> Job qualified to org.jboss.portal.core.portlet.itera.portlets.content.Job

      BUILD FAILED
      C:\programy\eclipse\workspace\jboss-portal-2.0-commerce\core\build.xml:141: null

      Total time: 28 seconds

      I set environmet for ant, in Eclipse:
      ANT_OPTS=-Xmx640m
      ANT_HOME=...... (directory with ant plugins for Eclipse)

      The compiling JBossPortal without Eclipse (with: ant build.xml deploy) is OK.
      Why i can't compile JBossPortal over Eclipse?