3 Replies Latest reply on Jan 2, 2007 5:28 AM by Hendra Sasmita

    Failed

    Hendra Sasmita Newbie

      Hi all,
      I just installed jboss messaging 1.2.0 beta1 and try the queue-failover example.

      When it tried to copy application-server-killer.jar, I get this message

      --- Packages waiting for a deployer ---
      org.jboss.deployment.DeploymentInfo@9dae65fe { url=file:/C:/jboss/server/messaging-node0/deploy/application-server-killer.jar }
       deployer: null
       status: null
       state: INIT_WAITING_DEPLOYER
       watch: file:/C:/jboss/server/messaging-node0/deploy/application-server-
      killer.jar
       altDD: null
       lastDeployed: 1166785410910
       lastModified: 1166785410910
       mbeans:
      


      What do I need to do in order to be able to deploy this jar?


      Because I cannot use the jar, I tried to shutdown the server manually. So I used two messaging servers. After I receive first message, I shut down the messaging-node0 (my first messaging server).

      Then I get this message in client-side :
      [java] 12:01:02,196 WARN @Thread-3 [HAAspect] Client attempted failover, but no failover attempt has been detected on the server side.
      


      And in the failover node, I get this message:
      12:00:59,152 INFO [ServerPeer] ServerPeer[1] waiting for server-side failover for failed node 0 to complete
      12:01:02,156 INFO [ServerPeer] ServerPeer[1] already waited long enough for failover to start, giving up
      


      I don't know what should I do to make the server failover works. Can Anybody point it out?

      Regards,
      Hendra