3 Replies Latest reply on Jan 28, 2007 12:38 AM by Ovidiu Feodorov

    "Failed to config client side AOP" RuntimeException when sen

    Chris Logan Newbie

      I am getting the exception "java.lang.RuntimeException: Failed to config client side AOP" at org.jboss.jms.client.JBossConnectionFactory.ensureAOPConfigLoaded(JBossConnectionFactory.java:252) when attempting to send a message to a remote JBoss Messaging server running 1.0.1.CR3 on JBossAS 4.0.5.GA.

      My messaging client is running within an application deployed in JBoss with the same version of JBoss Messaging and AS as specified above.

      I have looked at several other posts similar to this one, but it's clear to me that the others had clients that were running within JBoss. My suspicion is that the version of JBoss Remoting in the jboss-messaging-client.jar for JBoss Messaging 1.0.1.CR3 is different than that in the JBoss server lib, and the JBoss Remoting from the server is being used instead. I've pieced this together from various other posts.

      I would be grateful for any help. Thanks.
      Chris

        • 1. Re:
          Peter Johnson Master

          Are you getting any errors on the server? I got this same error yesterday on the client, and it was in response to an error on the server (in my case I was setting up SSL, and had misconfigured one of the remoting mbeans). Fixing the problem on the server solved thep roblem.

          • 2. Re:
            Chris Logan Newbie

            Yes, this is the error that I am getting on the remote server:

            2007-01-10 16:36:30,699 ERROR [org.jboss.remoting.transport.socket.ServerThread] failed to process invocation.
            java.io.IOException: Can not read data for version 3. Supported versions: 1,2
            at org.jboss.remoting.transport.socket.ServerThread.versionedRead(ServerThread.java:383)
            at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:435)
            at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:516)
            at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:253)

            I am suspecting that I need to created a scoped EAR as specified in Ovidiu's document http://wiki.jboss.org/wiki/Wiki.jsp?page=JBossMessagingUser_Deploying_a_scoped_MDB_container

            Currently, I am including the jboss-messaging-client.jar in my EAR (in which the client is running).

            • 3. Re:
              Ovidiu Feodorov Master

              A messaging installation on any 4.0.x server HAS to be scoped, because we're using newer (and unfortunately, incompatible) dependecies. There is no way around this.

              This situation will be corrected in 4.2 and 5.0, where we will keep our dependencies in sync.

              And btw, why are you using CR3? That's an ancient version ...