0 Replies Latest reply on Mar 26, 2007 11:37 AM by sam ramirez

    NumberFormatException on startup

    sam ramirez Newbie


      Following the installation instructions in the JBoss Messaging 1.2 User's Guide, I keep getting this warning message on startup:

      10:53:23,855 WARN [ServiceController] Problem creating service jboss.messaging:service=Connector,transport=bisocket
      java.lang.NumberFormatException: For input string: "0:0:0:0:0:0:1:4457"
      .
      .
      .
      and then I get the following FAIL message further down in the log:
      .
      .
      .
      ObjectName: jboss.messaging:service=Connector,transport=bisocket
      State: FAILED
      Reason: java.lang.NumberFormatException: For input string: "0:0:0:0:0:0:1:4457"
      I Depend On:
      jboss.messaging:service=NetworkRegistry
      Depends On Me:
      jboss.messaging.connectionfactory:service=ConnectionFactory
      jboss.messaging.connectionfactory:service=NonClusteredConnectionFactory
      jboss.messaging:service=ServerPeer
      .
      .
      .
      and finally:
      .
      .
      .
      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.messaging:service=Connector,transport=bisocket
      State: FAILED
      Reason: java.lang.NumberFormatException: For input string: "0:0:0:0:0:0:1:4457"
      I Depend On:
      jboss.messaging:service=NetworkRegistry
      Depends On Me:
      jboss.messaging.connectionfactory:service=ConnectionFactory
      jboss.messaging.connectionfactory:service=NonClusteredConnectionFactory
      jboss.messaging:service=ServerPeer


      I'm new to JBM and can't seem to figure out this problem. Any clues?

      I've attempted to run this as root and I've turned off firewalls and security thinking that ports might be blocked.

      I've switched JVMs and JBoss app servers, thinking this is an API issue.

      It appears that I have set the JAVA_HOME and JBOSS_HOME env vars correctly. My PATH looks correct. I think I"m running the JVM the environment says I'm running.

      Currently, I'm getting the above errors using the following:

      JBoss 4.0.5.GA
      Messaging 1.2.0.GA
      jdk 1.5.0_06 (tried with 1.4.2_13 & 1.6.0, same errors)
      Fedora 6 32-bit

      Any pointers in the right direction will be much appreciated.

      Thanks,
      Sam