4 Replies Latest reply on Oct 12, 2007 8:27 AM by Tim Fox

    Question about jboss-messaging-1.4.0.GA and #JBMESSAGING-999

    Leif Olsen Newbie

      Hello,

      I am experiencing the same issues as described in #JBMESSAGING-999, Bridge startup should retry if remote destinations are not available.

      I have the following scenario:

      Start server with bridge
      Produces some messages (using the producing part of the bridge example)
      I browse the jbm_msg table to verify that messages are there.
      Start server where messages shall be bridged to
      Consumes some messages (using the consuming part of the bridge example)
      No messages to consume. The messages are still stuck on the bridging side

      Everything works ok if I redeploy the bridge while both servers are running. The messages are now bridged.

      I have tried to deploy two messaging nodes on the same computer as well as deploying one messaging node (the one without the bridge) on a different computer. Both gives same result.

      Is #JBMESSAGING-999 fixed or is it just me missing some configuration details?


      Question about jboss-remoting 2.2.2.SP1 jar:
      Chapter 4, JBoss Messaging Installation,
      http://labs.jboss.com/file-access/default/members/jbossmessaging/freezone/docs/userguide-1.4.0.GA/html/installation.html
      states that you shall download jboss-remoting 2.2.2.SP1 from here:
      http://repository.jboss.com/jboss/remoting/2.2.2.SP1-brew/lib/

      The blog post,
      http://labs.jboss.com/blog/jbossmessaging_1_4_0_ga_released
      states that jboss-remoting 2.2.2.SP1 shall be downloaded from here:
      http://repository.jboss.com/jboss/remoting/2.2.2.SP1/lib/

      The two jar files are not identical in size, so this is a bit confusing.
      What is the correct jar?


      Regards
      Leif Olsen

      My environment:
      WinXP
      jdk1.6.0
      jboss-4.2.1.GA
      MySql5
      jboss-messaging-1.4.0.GA
      jboss-remoting 2.2.2.SP1 (from http://repository.jboss.com/jboss/remoting/2.2.2.SP1/lib/)