4 Replies Latest reply on Nov 12, 2007 3:50 AM by Frederic VERGEZ

    JBoss Messaging 1.2 and JBoss AS 4.2.2

    Frederic VERGEZ Newbie

      Hello,

      I have all the difficulties in the world running JBM 1.2 on a 4.2.2 AS.

      Installation works well, but a simple test (examples/queue) fails with:


      16:34:55,983 INFO [Server] JBoss (MX MicroKernel) [4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)] Started in 30s:968ms
      16:35:06,312 ERROR [SocketClientInvoker] Got marshalling exception, exiting
      java.io.IOException: Can not write data for version 22. Supported versions: 1, 2
       at org.jboss.remoting.transport.socket.MicroSocketClientInvoker.versionedWrite(MicroSocketClientInvoker.java:963)
       at org.jboss.remoting.transport.socket.MicroSocketClientInvoker.transport(MicroSocketClientInvoker.java:552)
       at org.jboss.remoting.transport.bisocket.BisocketClientInvoker.transport(BisocketClientInvoker.java:269)
       at org.jboss.remoting.MicroRemoteClientInvoker.invoke(MicroRemoteClientInvoker.java:122)
       at org.jboss.remoting.Client.invoke(Client.java:1513)
       at org.jboss.remoting.Client.invoke(Client.java:527)
       at org.jboss.remoting.Client.invokeOneway(Client.java:577)
       at org.jboss.remoting.callback.ServerInvokerCallbackHandler.handleCallback(ServerInvokerCallbackHandler.java:687)
       at org.jboss.remoting.callback.ServerInvokerCallbackHandler.handleCallbackOneway(ServerInvokerCallbackHandler.java:564)
       at org.jboss.jms.server.endpoint.ServerConsumerEndpoint.handle(ServerConsumerEndpoint.java:294)
       at org.jboss.messaging.core.local.RoundRobinPointToPointRouter.handle(RoundRobinPointToPointRouter.java:120)
       at org.jboss.messaging.core.ChannelSupport.deliverInternal(ChannelSupport.java:600)
       at org.jboss.messaging.core.ChannelSupport.deliver(ChannelSupport.java:306)
       at org.jboss.jms.server.endpoint.ServerSessionEndpoint$2.run(ServerSessionEndpoint.java:949)
       at EDU.oswego.cs.dl.util.concurrent.QueuedExecutor$RunLoop.run(QueuedExecutor.java:89)
       at java.lang.Thread.run(Thread.java:595)
      16:35:06,327 WARN [DefaultCallbackErrorHandler] DefaultCallbackErrorHandler[SocketServerInvoker[127.0.0.1:4457]] reached maximum number of callback e
      rrors allowed (1). Will clean up callback hander now.
      16:35:06,343 ERROR [ServerInvokerCallbackHandler] Error handling callback
      java.rmi.MarshalException: Failed to communicate. Problem during marshalling/unmarshalling; nested exception is:
       java.io.IOException: Can not write data for version 22. Supported versions: 1, 2
       at org.jboss.remoting.transport.socket.SocketClientInvoker.handleException(SocketClientInvoker.java:122)
       at org.jboss.remoting.transport.socket.MicroSocketClientInvoker.transport(MicroSocketClientInvoker.java:639)
       at org.jboss.remoting.transport.bisocket.BisocketClientInvoker.transport(BisocketClientInvoker.java:269)
       at org.jboss.remoting.MicroRemoteClientInvoker.invoke(MicroRemoteClientInvoker.java:122)
       at org.jboss.remoting.Client.invoke(Client.java:1513)
       at org.jboss.remoting.Client.invoke(Client.java:527)
       at org.jboss.remoting.Client.invokeOneway(Client.java:577)
       at org.jboss.remoting.callback.ServerInvokerCallbackHandler.handleCallback(ServerInvokerCallbackHandler.java:687)
       at org.jboss.remoting.callback.ServerInvokerCallbackHandler.handleCallbackOneway(ServerInvokerCallbackHandler.java:564)
       at org.jboss.jms.server.endpoint.ServerConsumerEndpoint.handle(ServerConsumerEndpoint.java:294)
       at org.jboss.messaging.core.local.RoundRobinPointToPointRouter.handle(RoundRobinPointToPointRouter.java:120)
       at org.jboss.messaging.core.ChannelSupport.deliverInternal(ChannelSupport.java:600)
       at org.jboss.messaging.core.ChannelSupport.deliver(ChannelSupport.java:306)
       at org.jboss.jms.server.endpoint.ServerSessionEndpoint$2.run(ServerSessionEndpoint.java:949)
       at EDU.oswego.cs.dl.util.concurrent.QueuedExecutor$RunLoop.run(QueuedExecutor.java:89)
       at java.lang.Thread.run(Thread.java:595)
      Caused by: java.io.IOException: Can not write data for version 22. Supported versions: 1, 2
       at org.jboss.remoting.transport.socket.MicroSocketClientInvoker.versionedWrite(MicroSocketClientInvoker.java:963)
       at org.jboss.remoting.transport.socket.MicroSocketClientInvoker.transport(MicroSocketClientInvoker.java:552)
       ... 14 more
      16:35:06,374 WARN [SimpleConnectionManager] ConnectionManager[3b8219] cannot look up remoting session ID 5c4o4o18-qq65cj-f8rfyd9c-1-f8rfydoz-4
      16:35:06,390 WARN [SimpleConnectionManager] A problem has been detected trying to send a message to remote client 5c4o4o18-qq65cj-f8rfyd9c-1-f8rfydoz
      -4. It is possible the client has exited without closing its connection(s) or there is a network problem. All connection resources corresponding to th
      at client process will now be removed.
      


      In documentation, version 1.2 seems to be runnable on a 4.2.1

      Any idea ?




        • 1. Re: JBoss Messaging 1.2 and JBoss AS 4.2.2
          Ovidiu Feodorov Master

          JBM 1.2 installation script was not designed to be forward compatible. JBAS 4.2.2 was released after JBM 1.2, so hardship is to be expected.

          JBM 1.2 tries to create a scoped (isolated) deployment.

          Why don't you use JBM 1.4.0.SP1?

          • 2. Re: JBoss Messaging 1.2 and JBoss AS 4.2.2
            Frederic VERGEZ Newbie

            Very good question, complicated aswer:

            I've already used JBM 1.4.0 with success, my problem is that i've got 2 version of JBoss that must share JMS communication:
            - "client" JBoss AS 4.0.4 GA, with consumers MDB beans connected to a remote JMS provider ..
            - ... remote JMS provider installed on a 4.2.2GA JBoss AS.

            JBM 1.4.0 works flawlessly with AS 4.2.2 on both sides, but i think it is not intended to work with JBoss AS 4.0.x version, am i right ?

            To make it simple:
            - 4.0.4 AS version on "MDB side" is mandatory for warranty and compatibility purposes (ILOG/JRules must run on a 4.0.4 GA to enable support :( )
            - a 4.2.x (and later 5.x) must be present on the other side to run the remote JMS provider (EJB3 dev coming)

            What version of JBM must i use to achieve that ? JBM v1.2 seemed a good concurent, but now i doubt it ...

            I was wondering if there is any compatibility matrix for JBoss AS and JBM versions ?

            And thank you for your response.

            • 3. Re: JBoss Messaging 1.2 and JBoss AS 4.2.2
              Ovidiu Feodorov Master

               

              "ikarius" wrote:

              JBM 1.4.0 works flawlessly with AS 4.2.2 on both sides, but i think it is not intended to work with JBoss AS 4.0.x version, am i right ?


              You can make it work, with some effort. Said effort should not be bigger than making 1.2 working with 4.2.x, so if you're already on that path, I would try 1.4



              • 4. Re: JBoss Messaging 1.2 and JBoss AS 4.2.2
                Frederic VERGEZ Newbie

                Thank you for your answer.
                I've made some progress on that way and remote JMS now works.