1 Reply Latest reply on Apr 23, 2008 8:54 AM by Andy Taylor

    Disable prefetch

    David Corcoran Newbie

      Hi,

      I'm evaluating JBoss messaging and it seems great so far but I've run into a small problem. We're currently using ActiveMQ and have found it to be too unstable, but one of the things it allows you is to set the PrefetchPolicy to 0. In JBoss Messaging if I set PrefetchSize to 0 I get an exception when I create a consumer.

      Is it possible to disable prefetch altogether? I know this isn't great for performance but for the time being at least I want to just do a straight forward port of our ActiveMQ code.

      Thanks

        • 1. Re: Disable prefetch
          Andy Taylor Master

           

          s it possible to disable prefetch altogether?

          setting the prefetch size to 1 should do the trick.

          I'm evaluating JBoss messaging and it seems great so far

          thats great! you may be interested to know that JBM 2, which is available towards the end of the year, will be much quicker and a lot more scalable. The alpha release will be available in the next few weeks.