4 Replies Latest reply on Jul 8, 2008 2:13 PM by Peter Johnson

    Problem with JBoss

    aaa cvvv Newbie

      Hello, I have this problem warking with IDE Eclipse.
      Jboss return this message in step di deploy

      Buildfile: E:\Michele\Lavoro&Studio\eclipse\plugins\org.eclipse.jst.server.generic.jboss_1.5.105.v200709061325\buildfiles\jboss323.xml
      deploy.j2ee.ejb:
      [jar] Building jar: E:\Michele\Lavoro&Studio\WorkSpace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\CodiceFiscale.jar
      [move] Moving 1 file to C:\jboss-4.2.0.GA\server\default\deploy

      and then throw a java.lang.nullpointer...

      where is the problem?
      thank you for the responses...Hello

        • 1. Re: Problem with JBoss
          Tim Fox Master

           

          "milkyboss" wrote:

          where is the problem?
          thank you for the responses...Hello


          Unfortunately my crystal ball is currently out of action so I can't help you out here.

          • 2. Re: Problem with JBoss
            aaa cvvv Newbie

            From Command Shell, JBoss retruns this message
            C:\jboss-4.2.0.GA\bin>run.bat
            JAVA_HOME is not set. Unexpected results may occur.
            Set JAVA_HOME to the directory of your local JDK to avoid this message.
            ===============================================================================

            JBoss Bootstrap Environment

            JBOSS_HOME: C:\jboss-4.2.0.GA

            JAVA: java

            JAVA_OPTS: -Dprogram.name=run.bat -server -Xms128m -Xmx512m -Dsun.rmi.dgc.cli
            ent.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

            CLASSPATH: C:\jboss-4.2.0.GA\bin\run.jar

            ===============================================================================

            Error: no `server' JVM at `C:\Programmi\Java\jre1.6.0_06\bin\server\jvm.dll'.
            Premere un tasto per continuare . . .

            please HELP... hello

            • 3. Re: Problem with JBoss
              aaa cvvv Newbie

              From Command Shell, JBoss retruns this message
              C:\jboss-4.2.0.GA\bin>run.bat
              JAVA_HOME is not set. Unexpected results may occur.
              Set JAVA_HOME to the directory of your local JDK to avoid this message.
              ===============================================================================

              JBoss Bootstrap Environment

              JBOSS_HOME: C:\jboss-4.2.0.GA

              JAVA: java

              JAVA_OPTS: -Dprogram.name=run.bat -server -Xms128m -Xmx512m -Dsun.rmi.dgc.cli
              ent.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

              CLASSPATH: C:\jboss-4.2.0.GA\bin\run.jar

              ===============================================================================

              Error: no `server' JVM at `C:\Programmi\Java\jre1.6.0_06\bin\server\jvm.dll'.
              Premere un tasto per continuare . . .

              please HELP... hello

              • 4. Re: Problem with JBoss
                Peter Johnson Master

                You have not set JAVA_HOME correctly. Set it to where you installed the JDK. On my box, I have JAVA_HOME set to c:\apps\jdk-1.5.0_15.