1 Reply Latest reply on Oct 24, 2008 6:05 AM by Noel O'Connor

    Accessing jnp port 1099

    Bharath VN Newbie

      Hi,

      We have been using jboss messaging 1.0.1.SP4 with Jboss-4.0.4 and we were not doing anything specific settings for the jnp port

      We upgraded to jboss-4.2.3 and when jboss-messaging 1.0.1.SP4 was deployed in this, the jnp port was not accessible remotely (and hence not able to publish messages).

      To have it working we made the followig configurations.

      1. To specify the host during startup

      run.sh -c messaging --host=192.168.200.50
      


      2. setting an empty BindAddress in JBOSS_HOME/server/messaing/conf/jboss-service.xml
       <attribute name="Port">1099</attribute>
      
       <!-- The bootstrap JNP server bind address. This also sets the default
      
       RMI service bind address. Empty == all addresses
      
       -->
      
       <attribute name="BindAddress"></attribute>
      



      My question is whether configuration being done is correct or is there an other way to have this working and why the default settings doesnt work with jboss-4.2.3

      Any pointers regarding this will be helpful

      Thanks,
      bnarayan