1 Reply Latest reply on Dec 4, 2008 4:52 AM by Tim Fox

    Jboss-messaging-1.0.5SP1 and Seam 2.0.2SP1 on jboss4.0.5

    Edwin van der Elst Newbie

      I am trying to use a (remote) jboss-messaging 1.0.5SP1 from within a Seam application (2.0.2SP1). I cannot upgrade JBoss or JBoss Messaging at this moment (there are many applications talking to that messaging server, upgrading would mean a lot of work).

      The problems I encounter are with classloading. I tried a 'scoped deployment', but run into errors concerning the javassist:

      java.lang.ClassCastException: nl.mypackage.User_$$_javassist_9 cannot be cast to javassist.util.proxy.ProxyObject

      This is after putting the same javassist.jar in the (scoped) jboss-messasing.sar. With the default javassists, I get method not found errors in the ProxyFactory class.

      I also tried putting all the jboss-messaging client jars in the ear file, but this gives other problems with the initialization of the 'aop on the client side'.

      Is it even possible what I am trying to do, or should I give up at this point (and wait for an upgrade of all the other applications)?

      All tips are welcome!

      Edwin