2 Replies Latest reply on Jun 16, 2009 7:09 AM by Yong Hao Gao

    Unable to create remote JMS Provider

    ermes martino Newbie

      Hi all,
      I'm trying to set up the JBM Bridge between two servers.
      On one machine I have added the remote Provider which point to another JMS Server:

      <mbean code="org.jboss.jms.jndi.JMSProviderLoader"
       name="jboss.messaging:service=JMSProviderLoader,
       name=MyRemoteJMSProvider">
       <attribute name="ProviderName">RemoteXAConnectionFactory</attribute>
       <attribute name="ProviderAdapterClass">org.jboss.jms.jndi.JNDIProviderAdapter</attribute>
      
       <attribute name="FactoryRef">XAConnectionFactory</attribute>
      
       <attribute name="QueueFactoryRef">XAConnectionFactory</attribute>
      
       <attribute name="TopicFactoryRef">XAConnectionFactory</attribute>
      
       <attribute name="Properties">java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory
       java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces
       java.naming.provider.url=10.2.20.246:1099
       </attribute>
      </mbean>


      Then I have added the bridge configuration file :

      <mbean code="org.jboss.jms.server.bridge.BridgeService"
       name="jboss.messaging:service=Bridge,name=TestBridge"
       xmbean-dd="xmdesc/Bridge-xmbean.xml">
       <depends optional-attribute-name="SourceProviderLoader">
       jboss.messaging:service=JMSProviderLoader,name=JMSProvider</depends>
       <depends optional-attribute-name="TargetProviderLoader">
       jboss.messaging:service=JMSProviderLoader,name=MyRemoteJMSProvider</depends>
       <attribute name="SourceDestinationLookup">/queue/exampleQueue1</attribute>
       <attribute name="TargetDestinationLookup">/queue/exampleQueue2</attribute>
       <attribute name="MaxBatchSize">5</attribute>
       <attribute name="MaxBatchTime">-1</attribute>
      
      
      </mbean>


      however, as soon as I copy these files in the deploy folder the following error is issued:

      17:37:47,803 WARN [HDScanner] Failed to process changes
      org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):
      
      *** CONTEXTS MISSING DEPENDENCIES: Name -> Dependency{Required State:Actual State}
      
      jboss.messaging:name=TestBridge,service=Bridge
       -> jboss.messaging:name=MyRemoteJMSProvider,service=JMSProviderLoader{Create:**
       NOT FOUND Depends on 'jboss.messaging:name=MyRemoteJMSProvider,service=JMSProviderLoader' **}
      
      
      *** CONTEXTS IN ERROR: Name -> Error
      
      jboss.messaging:name=MyRemoteJMSProvider,service=JMSProviderLoader -> ** NOT FOUND Depends on 'jboss.messaging:name=MyRemoteJMSProvider,service=JMSProviderLoade
      r' **


      It seems that MyRemoteJMSProvider is not found, however from the JMX console I can see that it it actually deployed......
      I'm running JBoss 5.0.0 GA, is there any issue with this release ?
      thanks
      marco