1 Reply Latest reply on May 20, 2009 3:11 AM by uday kumar

    Unable to configure a topic in Jboss 5

    uday kumar Newbie

      Hi,
      I'm new to JBoss Messaging services. I started with simple Queue example. It was deployed well and able to taste the result.

      Now the problem is, i"m unable to configure the TOPIC.What i did is
      1)I'm using the default (as deployment folder).
      2) I created the xml file and named as

      jboss-topic-service.xml
      . in default/config folder
      3)I written the below code in that.
      <server>
      <mbean code="org.jboss.jms.server.destination.TopicService"
       name="jboss.messaging.destination:service=Topic,name=testTopic"
       xmbean-dd="xmdesc/Topic-xmbean.xml">
       <depends optional-attribute-name="ServerPeer">jboss.messaging:service=ServerPeer</depends>
       <depends>jboss.messaging:service=PostOffice</depends>
       <attribute name="SecurityConfig">
       <security>
       <role name="guest" read="true" write="true"/>
       <role name="publisher" read="true" write="true" create="false"/>
       <role name="durpublisher" read="true" write="true" create="true"/>
       </security>
       </attribute>
       </mbean>
      </server>

      4)when i start my jboss with default as deployment option, I'm unable to see my topic in the console. Here is the console output.
      12:13:53,352 INFO [ServerPeer] JBoss Messaging 1.4.1.GA server [0] started
      12:13:53,461 INFO [QueueService] Queue[/queue/ExpiryQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      12:13:53,539 INFO [QueueService] Queue[/queue/testQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      12:13:53,618 INFO [ConnectionFactory] Connector bisocket://127.0.0.1:4457 has leasing enabled, lease period 10000 milliseconds
      12:13:53,618 INFO [ConnectionFactory] org.jboss.jms.server.connectionfactory.ConnectionFactory@1f4ed3f started

      5) In the above console output we can able to see the queue service has been configured well but Topic is not.

      Please help me in this . What's wrong with the configuration. Please let me know is there any thing to do in order to deal with TOPIC example.

      I even checked by removing the SecurityConfig attribute in jboss-topic-service.xml. But no use.

      Help me in this.