0 Replies Latest reply on Sep 4, 2009 9:00 AM by Paul Chuang

    unregistered connectionendpoint with remoting session ID

    Paul Chuang Newbie

      Hi All,
      I have been dealing with this problem for the last several days and hope someone knows the answer.

      I have 2 servers (desktopwin and pclinux), each running jboss5.1 as "run -c all -b 0.0.0.0". The servlet on desktopwin sends a message to the queue on pclinux, the msg driven bean on pclinux receives the message correctly. The problem is the other way around, when the servlet on linuxpc sends a message to the queue on desktopwin, the msg driven bean on desktopwin never receives it. I turned on DEBUG, and traced down the following:

      DEBUG [org.jboss.jms.server.connectionmanager.SimpleConnectionManager] (WorkerThread#0[172.17.2.23:45004]) unregistered connection ConnectionEndpoint[hd-gdsxbxyf-1-nxbubxyf-80upyq-100j3] with remoting session ID ...-fbmmit9w-dj

      I tried to run the above scenario on 2 windows system (desktopwin and laptopwin). It worked fine, messages were received on both msg driven beans as expected. I also noticed that the same code running on windows environment used org.jboss.remoting.ServerInvoker instead of org.jboss.jms.server.connectionmanager.SimpleConnectionManager as indicated in the debug trace:

      DEBUG [org.jboss.remoting.ServerInvoker] (WorkerThread#0[172.17.5.11:1763]) Thread pool class supplied is not an object name

      For provider_url, I was using jnp://remotehost:1099.

      Thank you in advance.

      Paul