2 Replies Latest reply on Sep 29, 2009 4:04 AM by Ali Gohar

    JBoss Messaging Issues

    Ali Gohar Newbie

      Hi,

      I have JBoss-4.0.2 and JBoss-5.1.0.GA on my machine and I am trying to run both at the same time. I am running the "all" configuration for both of them. I've changed the ports for jboss 5 to use ports-02 and jboss 4 is using the default ports. Now when i start Jboss4 first it starts fine and then I start jboss5 is throws exception that:

      2009-09-28 17:09:01,655 ERROR [org.jboss.messaging.util.ExceptionUtil] (main) Queue[/queue/DLQ] startService
      javax.jms.InvalidDestinationException: Destination DLQ already exists
       at org.jboss.jms.server.DestinationJNDIMapper.registerDestination(DestinationJNDIMapper.java:122)
       at org.jboss.jms.server.destination.QueueService.startService(QueueService.java:150)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:376)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:322)
       at sun.reflect.GeneratedMethodAccessor80.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
       at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:138)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:90)
       at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:140)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:90)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:668)
       at org.jboss.system.microcontainer.ServiceProxy.invoke(ServiceProxy.java:189)
       at $Proxy38.start(Unknown Source)
      


      Anyways but the jboss starts up. So when both are up there is a client deployed in jboss4 which connects to a particular queue which is deployed on jboss4 and not on jboss5. When it tries to put the message on queue, It throws error as following:
      2009-09-28 15:46:47,891 DEBUG [net.plus.envoy.bt.jms.JmsSenderImpl] Queued message scheduled to be sent at Mon Sep 28 15:47:47 BST 2009
      2009-09-28 15:46:47,908 WARN [org.jboss.resource.connectionmanager.JBossManagedConnectionPool] Throwable while attempting to get a new connection: null
      javax.resource.spi.CommException: javax.naming.CommunicationException [Root exception is java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.jms.client.JBossConnectionFactory (no security manager: RMI class loader disabled)]
       at org.jboss.resource.adapter.jms.JmsManagedConnection.setup(JmsManagedConnection.java:743)
       at org.jboss.resource.adapter.jms.JmsManagedConnection.<init>(JmsManagedConnection.java:172)
       at org.jboss.resource.adapter.jms.JmsManagedConnectionFactory.createManagedConnection(JmsManagedConnectionFactory.j
      


      Don't know why is it using org.jboss.jms.client.JBossConnectionFactory instead of using jboss mq as queue is on jboss4.

      Any idea?

      Thanks