3 Replies Latest reply on Mar 3, 2014 5:41 AM by Jo Boe

    Upgrade JBoss AS 5.1.0 to JBoss Messaging 1.4.5.GA?

    Richard Kennard Novice

      Hi guys,

      Are there special considerations involved in upgrading JBoss 5.1.0 to use the new JBoss Messaging 1.4.5.GA? I'm keen to be updated on the latest bugfixes.

      I tried just copying the jboss-messaging.jar into JBoss, but now none of my queues are recognised:

      [org.jboss.resource.adapter.jms.inflow.JmsActivation] Failure in jms activation org.jboss.resource.adapter.jms.inflow.JmsActivationSpec@15e154a(ra=org.jboss.resource.adapter.jms.JmsResourceAdapter@9b7ca4 destination=jnp://localhost:1100/queue/avant-ss-production.emails destinationType=javax.jms.Queue tx=true durable=false reconnect=10 provider=java:/DefaultJMSProvider user=null maxMessages=1 minSession=1 maxSession=15 keepAlive=60000 useDLQ=false)
      javax.naming.NameNotFoundException: queue not bound


      I also note there is no equivalent jboss-messaging-int.jar. Does there need to be?

      Regards,

      Richard.