0 Replies Latest reply on Sep 28, 2006 3:41 AM by Brett Cprbin

    Netbeasn 5.5 Beta2 budled with Jboss 4.0.4 problems

    Brett Cprbin Newbie

      I have just downloaded this bundled and installed based on the instructions from: http://www.netbeans.org/community/releases/55/install-jboss-bundle.html

      I then tried to follow the EJB3.0 Enterprise beans for the JBoss Application Server from here: http://www.netbeans.org/kb/55/ejb30-jboss.html

      Unfortunately, when I follow these instructions, netbeans is behaving as stated. First when creating a new Entity, instead of Netbeans saying
      @Entity it is coming up us
      @javax.persistence.Entity

      When I go one, Netbeans cannot find other objects such as MessageDriven, MessageListener etc, I can add the imports in manually to get rid of the error message, but is that right.

      Also when I get to the step to right click my code and select 'Persistence -> Use Entity Manager' the code that should be added by Netbeans isn't.

      The when trying to create a Session Beans for Entity Classes, Netbeans lists not Entity's to choose from.


      I then tried to follow the details about Java Persistence in the Java 33 5 platform, and it says create a new Web Application as Java EE 5, but my Jboss Application will only list J2EE 1.4 in the drop down.

      Am I missing something?

      Also I do not see how Hibernate is set up with Jboss 4.0.4, is it actually accesible by default or do I need to move/downlaod specific jars?