4 Replies Latest reply on Feb 1, 2007 5:14 AM by Libor Kotouc

    JBoss 4.0.4 only recognized as J2EE 1.4 for web projects

    Anders Bergquist Newbie

      Hi

      I've installed JBoss 4.0.4 GA and choose EJB3-CLUSTER mode in order to use Java EE 5 stuff.

      Netbeans version 5.5 RC2

      Importing the server is no problem.

      Creating an Entprise project also works great. Java EE version can be set to 5 och 1.4.

      The problem is when I want to create a web application project I only get the Java version 1.4.

      Reason I want to use EE 5 i because when adding a Web Service Client to the project the JAX version is set to JMX-RPC but I need JMX-WS.
      (Creating a standard J2SE project and adding the web servie client I get the JMX-WS version as the only choice)

      How can I get around this?

      Regards abq