5 Replies Latest reply on May 4, 2007 10:41 PM by Lee Minh

    Unable to deploy / run to JBoss from Netbeans, port 8080, 10

    Daniel Eriksson Newbie

      Hello,

      Im using NetBeans 5.5 and just installed JBoss-4.0.5.GA for evaluation and I run into problems when I try to deploy or run projects from NetBeans.
      It seems like NetBeans try to start JBoss everytime I try to deploy or run an J2EE application and is unable trying to rebind the port already used by JBoss..
      First it was port 8080 then I tried changeing port 8080 in server.xml but then it was port 1099 and if I try to change that port it only fails on the new port. Have anyone got this working?

      Also I never get a indication in Netbeans under Runtime->Servers that JBoss is running, I can start JBoss but it does not seem to have be able to get any status.

      Here are some error messages from Netbeans

      pre-init:
      init-private:
      init-userdir:
      init-user:
      init-project:
      do-init:
      post-init:
      init-check:
      init:
      deps-jar:
      deps-j2ee-archive:
      init:
      init:
      deps-jar:
      compile:
      library-inclusion-in-manifest:
      dist-ear:
      deps-jar:
      compile:
      library-inclusion-in-manifest:
      dist-ear:
      init:
      deps-jar:
      compile:
      library-inclusion-in-manifest:
      dist-ear:
      pre-pre-compile:
      pre-compile:
      do-compile:
      post-compile:
      compile:
      pre-dist:
      do-dist-without-manifest:
      do-dist-with-manifest:
      Building jar: E:\Development\Java\JBbossTest1\dist\JBbossTest1.ear
      post-dist:
      dist:
      pre-run-deploy:
      Starting server JBoss Application Server 4
      JBoss Application Server 4 Start Failed. HTTP Connector port 8080 is already in use.
      E:\Development\Java\JBbossTest1\nbproject\build-impl.xml:182: Deployment error:
      JBoss Application Server 4 Start Failed. HTTP Connector port 8080 is already in use.
      See the server log for details.
      BUILD FAILED (total time: 1 second)


      ....
      pre-dist:
      do-dist-without-manifest:
      do-dist-with-manifest:
      post-dist:
      dist:
      pre-run-deploy:
      Starting server JBoss Application Server 4
      JBoss Application Server 4 Start Failed. JNP service port 1199 is already in use.
      E:\Development\Java\JBbossTest1\nbproject\build-impl.xml:182: Deployment error:
      JBoss Application Server 4 Start Failed. JNP service port 1199 is already in use.
      See the server log for details.
      BUILD FAILED (total time: 4 seconds)