4 Replies Latest reply on Oct 6, 2005 9:52 AM by Gavin King

    Basic CRUD web app

    Jacob Hookom Newbie

      For simplicity's sake, I would consolidate it to one Action. In the add/change/delete process, you are dealing with one printer instance, or one reference within the CRUD Action.

      Conceptually, your Action has a Printer, either set one from a previous action/scope, or use one for creation. If you start to run into problems with referencing beans, possibly decrease your use of @In and @Out for everything and just specify your Action as a Seam Component and just reference that Actions properties via EL--

      #{printerAction.printer} vs. #{printer}

      It may help with readability too, while keeping lifecycle control of that printer within your Action itself.

      -- Jacob