2 Replies Latest reply on Oct 12, 2005 1:37 PM by Keith Davey

    Seam with Postgres Problem

    Keith Davey Newbie

      Hi,

      I have been working on moving the examples over to Postgres. On the surface everything appears to work well, until I changed some of the values
      in entities to use

      @Id(generate=GeneratorType.SEQUENCE, generator="MY_ID_GEN")


      I keep getting errors saying "could not get next sequence value".

      While looking through the logs I noticed this:

      2005-10-11 14:58:26,762 INFO [org.hibernate.cfg.SettingsFactory] RDBMS: PostgreSQL, version: 8.0.3
      2005-10-11 14:58:26,762 INFO [org.hibernate.cfg.SettingsFactory] JDBC driver: PostgreSQL Native Driver, version: PostgreSQL 8.0 JDBC3 with SSL (build 312)
      2005-10-11 14:58:26,762 DEBUG [org.jboss.mx.loading.UnifiedClassLoader] New jmx UCL with url null
      2005-10-11 14:58:26,762 DEBUG [org.jboss.mx.loading.RepositoryClassLoader] setRepository, repository=org.jboss.mx.loading.HeirarchicalLoaderRepository3@b90ff7, cl=org.jboss.mx.loading.UnifiedClassLoader3@1d5176d{ url=null ,addedOrder=0}
      2005-10-11 14:58:26,762 INFO [org.hibernate.dialect.Dialect] Using dialect: org.hibernate.dialect.HSQLDialect

      However, my persistence.xml has the following:


      <property name="dialect">org.hibernate.dialect.PostgreSQLDialect</property>
      
       <property name="hibernate.hbm2ddl.auto" value="create-drop"/>


      Is there somewhere else I should be setting the Dialect or is it just defaulting back to the HSLDialect.

      Thanks,

      Keith